summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2010-04-03 04:52:06 +0000
committerJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2010-04-03 04:52:06 +0000
commit21a1a3c4728a089e201b8b464ac16bc705857c8d (patch)
treea1a209351935cb36d8e7e90fe0207a768c896ce9 /x11-plugins
parentReplaced compiz ~ deps with >= deps to support the new compiz-0.8.6 release a... (diff)
downloadgentoo-2-21a1a3c4728a089e201b8b464ac16bc705857c8d.tar.gz
gentoo-2-21a1a3c4728a089e201b8b464ac16bc705857c8d.tar.bz2
gentoo-2-21a1a3c4728a089e201b8b464ac16bc705857c8d.zip
Replaced compiz ~ deps with >= deps to support the new compiz-0.8.6 release and to avoid future dep issues.
Did a revbump to avoid issues with installed packages. (Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/compiz-plugins-main/ChangeLog10
-rw-r--r--x11-plugins/compiz-plugins-main/compiz-plugins-main-0.8.6.ebuild51
2 files changed, 60 insertions, 1 deletions
diff --git a/x11-plugins/compiz-plugins-main/ChangeLog b/x11-plugins/compiz-plugins-main/ChangeLog
index 4141685e9707..d1c7c9e1b906 100644
--- a/x11-plugins/compiz-plugins-main/ChangeLog
+++ b/x11-plugins/compiz-plugins-main/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-plugins/compiz-plugins-main
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/compiz-plugins-main/ChangeLog,v 1.10 2010/01/31 17:00:45 mrpouet Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/compiz-plugins-main/ChangeLog,v 1.11 2010/04/03 04:52:06 jmbsvicetto Exp $
+
+*compiz-plugins-main-0.8.6 (03 Apr 2010)
+
+ 03 Apr 2010; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+ +compiz-plugins-main-0.8.6.ebuild:
+ Replaced compiz ~ deps with >= deps to support the new compiz-0.8.6
+ release and to avoid future dep issues.
+ Did a revbump to avoid issues with installed packages.
*compiz-plugins-main-0.8.4-r1 (31 Jan 2010)
diff --git a/x11-plugins/compiz-plugins-main/compiz-plugins-main-0.8.6.ebuild b/x11-plugins/compiz-plugins-main/compiz-plugins-main-0.8.6.ebuild
new file mode 100644
index 000000000000..7a7c6732af83
--- /dev/null
+++ b/x11-plugins/compiz-plugins-main/compiz-plugins-main-0.8.6.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/compiz-plugins-main/compiz-plugins-main-0.8.6.ebuild,v 1.1 2010/04/03 04:52:06 jmbsvicetto Exp $
+
+EAPI="2"
+
+inherit eutils gnome2-utils
+
+DESCRIPTION="Compiz Fusion Window Decorator Plugins"
+HOMEPAGE="http://www.compiz.org/"
+SRC_URI="http://releases.compiz.org/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="gnome"
+
+MY_PV="0.8.4"
+
+RDEPEND="
+ >=gnome-base/librsvg-2.14.0
+ media-libs/jpeg
+ x11-libs/cairo
+ >=x11-libs/compiz-bcop-${MY_PV}
+ >=x11-wm/compiz-${PV}[gnome?]
+"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.19
+ >=sys-devel/gettext-0.15
+"
+
+src_prepare() {
+ use gnome || epatch "${FILESDIR}"/${PN}-no-gconf.patch
+}
+
+src_configure() {
+ econf $(use_enable gnome schemas) || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
+pkg_preinst() {
+ use gnome && gnome2_gconf_savelist
+}
+
+pkg_postinst() {
+ use gnome && gnome2_gconf_install
+}