summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDon Seiler <rizzo@gentoo.org>2004-12-02 15:05:25 +0000
committerDon Seiler <rizzo@gentoo.org>2004-12-02 15:05:25 +0000
commit83a9826bbfef89619308dc1648375eeb19180384 (patch)
tree5c14fed9d10c1978016a2bbd82882209c2ac3923 /x11-plugins
parentFirst commit. (Manifest recommit) (diff)
downloadgentoo-2-83a9826bbfef89619308dc1648375eeb19180384.tar.gz
gentoo-2-83a9826bbfef89619308dc1648375eeb19180384.tar.bz2
gentoo-2-83a9826bbfef89619308dc1648375eeb19180384.zip
Going back to standalone NSPR/NSS dependency. MozillaFirefox does not provide pkgconfig and Mozilla is not available on all arches.
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/gaim-encryption/ChangeLog6
-rw-r--r--x11-plugins/gaim-encryption/gaim-encryption-2.32-r1.ebuild18
2 files changed, 17 insertions, 7 deletions
diff --git a/x11-plugins/gaim-encryption/ChangeLog b/x11-plugins/gaim-encryption/ChangeLog
index b4a2403e2bb9..552afbb1d345 100644
--- a/x11-plugins/gaim-encryption/ChangeLog
+++ b/x11-plugins/gaim-encryption/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-plugins/gaim-encryption
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gaim-encryption/ChangeLog,v 1.43 2004/11/29 20:01:50 rizzo Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gaim-encryption/ChangeLog,v 1.44 2004/12/02 15:05:25 rizzo Exp $
+
+ 02 Dec 2004; Don Seiler <rizzo@gentoo.org> gaim-encryption-2.32-r1.ebuild:
+ Going back to standalone NSPR/NSS dependency. MozillaFirefox does not
+ provide pkgconfig and Mozilla is not available on all arches.
29 Nov 2004; Don Seiler <rizzo@gentoo.org> gaim-encryption-2.32-r1.ebuild:
Allowing dep on mozilla-firefox and/or mozilla if users doesn't like
diff --git a/x11-plugins/gaim-encryption/gaim-encryption-2.32-r1.ebuild b/x11-plugins/gaim-encryption/gaim-encryption-2.32-r1.ebuild
index c6e39bb0e854..d9c1fb170e09 100644
--- a/x11-plugins/gaim-encryption/gaim-encryption-2.32-r1.ebuild
+++ b/x11-plugins/gaim-encryption/gaim-encryption-2.32-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gaim-encryption/gaim-encryption-2.32-r1.ebuild,v 1.3 2004/11/29 20:01:50 rizzo Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gaim-encryption/gaim-encryption-2.32-r1.ebuild,v 1.4 2004/12/02 15:05:25 rizzo Exp $
inherit flag-o-matic eutils debug
@@ -14,15 +14,21 @@ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~sparc ~x86 ~ppc64"
IUSE=""
DEPEND=">=net-im/gaim-1.0.1
- || ( >=dev-libs/nss-3.9.2-r2 net-www/mozilla-firefox net-www/mozilla )"
+ >=dev-libs/nss-3.9.2-r2"
src_compile() {
+ strip-flags
+ replace-flags -O? -O2
- econf || die "Configuration failed"
- einfo "Replacing -Os CFLAG with -O2"
- replace-flags -Os -O2
+ local myconf
+ myconf="${myconf} --with-nspr-includes=/usr/include/nspr"
+ myconf="${myconf} --with-nss-includes=/usr/include/nss"
+ myconf="${myconf} --with-nspr-libs=/usr/lib/nspr"
+ myconf="${myconf} --with-nss-libs=/usr/lib/nss"
- emake || emake -j1 || die "Make failed"
+ econf ${myconf} || die "Configuration failed"
+
+ emake || MAKEOPTS="${MAKEOPTS} -j1" emake || die "Make failed"
}
src_install() {