summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2010-05-19 09:43:17 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2010-05-19 09:43:17 +0000
commit99b9af50ff443067137040fd24dcb0f4d15bfbc9 (patch)
tree57540230547edd4e4a373c3292b3bc43fbdc2b70 /x11-plugins
parentMissing media-plugins/gst-plugins-gio RDEPEND wrt #319697. (diff)
downloadgentoo-2-99b9af50ff443067137040fd24dcb0f4d15bfbc9.tar.gz
gentoo-2-99b9af50ff443067137040fd24dcb0f4d15bfbc9.tar.bz2
gentoo-2-99b9af50ff443067137040fd24dcb0f4d15bfbc9.zip
Version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmudmount/ChangeLog8
-rw-r--r--x11-plugins/wmudmount/wmudmount-1.5.ebuild47
2 files changed, 54 insertions, 1 deletions
diff --git a/x11-plugins/wmudmount/ChangeLog b/x11-plugins/wmudmount/ChangeLog
index 161cc5a669ac..3d5b20341290 100644
--- a/x11-plugins/wmudmount/ChangeLog
+++ b/x11-plugins/wmudmount/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/wmudmount
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmudmount/ChangeLog,v 1.1 2010/04/07 15:03:18 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmudmount/ChangeLog,v 1.2 2010/05/19 09:43:17 voyageur Exp $
+
+*wmudmount-1.5 (19 May 2010)
+
+ 19 May 2010; Bernard Cafarelli <voyageur@gentoo.org>
+ +wmudmount-1.5.ebuild:
+ Version bump
*wmudmount-1.4 (07 Apr 2010)
diff --git a/x11-plugins/wmudmount/wmudmount-1.5.ebuild b/x11-plugins/wmudmount/wmudmount-1.5.ebuild
new file mode 100644
index 000000000000..d715309b1a27
--- /dev/null
+++ b/x11-plugins/wmudmount/wmudmount-1.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmudmount/wmudmount-1.5.ebuild,v 1.1 2010/05/19 09:43:17 voyageur Exp $
+
+EAPI=2
+inherit gnome2-utils
+
+DESCRIPTION="A filesystem mounter that uses udisks to handle notification and mounting"
+HOMEPAGE="http://sourceforge.net/projects/wmudmount/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome-keyring libnotify"
+
+RDEPEND=">=x11-libs/gtk+-2.18:2
+ dev-libs/dbus-glib
+ sys-fs/udisks
+ gnome-keyring? ( gnome-base/gnome-keyring )
+ libnotify? ( x11-libs/libnotify )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_with libnotify) \
+ $(use_with gnome-keyring)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc ChangeLog
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}