summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-03-24 19:42:04 +0000
committerJustin Lecher <jlec@gentoo.org>2015-03-24 19:42:04 +0000
commitbe6731eadd655baa9902eb021861ea1512601d78 (patch)
tree551c6a01efc1705b492c971f635431a44b853a48 /x11-plugins
parentVersion bump. Remove old. (diff)
downloadgentoo-2-be6731eadd655baa9902eb021861ea1512601d78.tar.gz
gentoo-2-be6731eadd655baa9902eb021861ea1512601d78.tar.bz2
gentoo-2-be6731eadd655baa9902eb021861ea1512601d78.zip
Fix build problems due to missing CFLAGS, #544090; respect LDFLAGS, #340957
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/gkrellstock/ChangeLog6
-rw-r--r--x11-plugins/gkrellstock/files/gkrellstock-0.5-ldflags.patch16
-rw-r--r--x11-plugins/gkrellstock/gkrellstock-0.5-r1.ebuild13
3 files changed, 32 insertions, 3 deletions
diff --git a/x11-plugins/gkrellstock/ChangeLog b/x11-plugins/gkrellstock/ChangeLog
index e8edd9985d93..3efddf06dc82 100644
--- a/x11-plugins/gkrellstock/ChangeLog
+++ b/x11-plugins/gkrellstock/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-plugins/gkrellstock
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellstock/ChangeLog,v 1.15 2015/03/20 16:10:37 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellstock/ChangeLog,v 1.16 2015/03/24 19:42:04 jlec Exp $
+
+ 24 Mar 2015; Justin Lecher <jlec@gentoo.org>
+ +files/gkrellstock-0.5-ldflags.patch, gkrellstock-0.5-r1.ebuild:
+ Fix build problems due to missing CFLAGS, #544090; respect LDFLAGS, #340957
*gkrellstock-0.5-r1 (20 Mar 2015)
diff --git a/x11-plugins/gkrellstock/files/gkrellstock-0.5-ldflags.patch b/x11-plugins/gkrellstock/files/gkrellstock-0.5-ldflags.patch
new file mode 100644
index 000000000000..116e6ec3e4bd
--- /dev/null
+++ b/x11-plugins/gkrellstock/files/gkrellstock-0.5-ldflags.patch
@@ -0,0 +1,16 @@
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index eb26b17..79e4391 100644
+--- a/Makefile
++++ b/Makefile
+@@ -10,7 +10,7 @@ CC = gcc $(CFLAGS) $(FLAGS)
+ OBJS = gkrellstock.o
+
+ gkrellstock.so: $(OBJS)
+- $(CC) $(OBJS) -o gkrellstock.so $(LFLAGS) $(LIBS)
++ $(CC) $(LDFLAGS) $(OBJS) -o gkrellstock.so $(LFLAGS) $(LIBS)
+
+ clean:
+ rm -f *.o core *.so* *.bak *~
diff --git a/x11-plugins/gkrellstock/gkrellstock-0.5-r1.ebuild b/x11-plugins/gkrellstock/gkrellstock-0.5-r1.ebuild
index 2f113631a521..1af6b89d415b 100644
--- a/x11-plugins/gkrellstock/gkrellstock-0.5-r1.ebuild
+++ b/x11-plugins/gkrellstock/gkrellstock-0.5-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellstock/gkrellstock-0.5-r1.ebuild,v 1.1 2015/03/20 16:10:37 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellstock/gkrellstock-0.5-r1.ebuild,v 1.2 2015/03/24 19:42:04 jlec Exp $
EAPI=5
-inherit gkrellm-plugin toolchain-funcs
+inherit flag-o-matic gkrellm-plugin toolchain-funcs
DESCRIPTION="Get Stock quotes plugin for Gkrellm2"
HOMEPAGE="http://gkrellstock.sourceforge.net/"
@@ -16,11 +16,20 @@ KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gtk+:2
dev-perl/libwww-perl
dev-perl/Finance-Quote"
+DEPEND="virtual/pkgconfig"
S=${WORKDIR}/${P/s/S}
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ldflags.patch
+ append-cppflags $($(tc-getPKG_CONFIG) --cflags gtk+-2.0)
+ append-flags -fPIC
+}
+
src_compile() {
emake CC=$(tc-getCC)
}