summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2012-11-20 18:58:12 +0000
committerAlex Alexander <wired@gentoo.org>2012-11-20 18:58:12 +0000
commitccc88db03ada31701cfbe3fc7b26d98c4484d408 (patch)
tree01b6b201f9d121c19a7496a8c93748caebb9607d /x11-plugins
parentversion bump (diff)
downloadgentoo-2-ccc88db03ada31701cfbe3fc7b26d98c4484d408.tar.gz
gentoo-2-ccc88db03ada31701cfbe3fc7b26d98c4484d408.tar.bz2
gentoo-2-ccc88db03ada31701cfbe3fc7b26d98c4484d408.zip
version bump, bug #438668 - new contrib use flag
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key EB9B4AFA)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/vicious/ChangeLog8
-rw-r--r--x11-plugins/vicious/metadata.xml3
-rw-r--r--x11-plugins/vicious/vicious-2.1.0.ebuild29
3 files changed, 39 insertions, 1 deletions
diff --git a/x11-plugins/vicious/ChangeLog b/x11-plugins/vicious/ChangeLog
index 21adc24c800e..0088a1d9ef50 100644
--- a/x11-plugins/vicious/ChangeLog
+++ b/x11-plugins/vicious/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/vicious
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/vicious/ChangeLog,v 1.9 2012/05/06 18:15:28 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/vicious/ChangeLog,v 1.10 2012/11/20 18:58:12 wired Exp $
+
+*vicious-2.1.0 (20 Nov 2012)
+
+ 20 Nov 2012; Alex Alexander <wired@gentoo.org> +vicious-2.1.0.ebuild,
+ metadata.xml:
+ version bump, bug #438668 - new contrib use flag
*vicious-2.0.4 (06 May 2012)
diff --git a/x11-plugins/vicious/metadata.xml b/x11-plugins/vicious/metadata.xml
index b174be1f0be2..b4c5a3f3c805 100644
--- a/x11-plugins/vicious/metadata.xml
+++ b/x11-plugins/vicious/metadata.xml
@@ -5,5 +5,8 @@
<email>wired@gentoo.org</email>
<name>Alex Alexander</name>
</maintainer>
+ <use>
+ <flag name="contrib">Install extra widgets, some for less common hardware, some contributed by Vicious users.</flag>
+ </use>
</pkgmetadata>
diff --git a/x11-plugins/vicious/vicious-2.1.0.ebuild b/x11-plugins/vicious/vicious-2.1.0.ebuild
new file mode 100644
index 000000000000..3bddc6c7a933
--- /dev/null
+++ b/x11-plugins/vicious/vicious-2.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/vicious/vicious-2.1.0.ebuild,v 1.1 2012/11/20 18:58:12 wired Exp $
+
+EAPI=5
+
+DESCRIPTION="Modular widget library for x11-wm/awesome"
+HOMEPAGE="http://awesome.naquadah.org/wiki/Vicious"
+SRC_URI="http://git.sysphere.org/${PN}/snapshot/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="contrib"
+
+DEPEND=""
+RDEPEND="x11-wm/awesome"
+
+src_install() {
+ insinto /usr/share/awesome/lib/vicious
+ doins -r widgets helpers.lua init.lua
+ dodoc CHANGES README TODO
+
+ if use contrib; then
+ insinto /usr/share/awesome/lib/vicious/widgets
+ doins contrib/*.lua
+ newdoc contrib/README README.contrib
+ fi
+}