summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-07-06 12:48:40 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-07-06 12:48:40 +0000
commitf48747168d9f1576f9fe0ea01940965314937ca0 (patch)
treeb2411bc0b27109ddb92101d9df73b0648c320382 /x11-plugins
parentPull in user.eclass for enewgroup. (diff)
downloadgentoo-2-f48747168d9f1576f9fe0ea01940965314937ca0.tar.gz
gentoo-2-f48747168d9f1576f9fe0ea01940965314937ca0.tar.bz2
gentoo-2-f48747168d9f1576f9fe0ea01940965314937ca0.zip
Version bump.
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmudmount/ChangeLog8
-rw-r--r--x11-plugins/wmudmount/files/wmudmount-headers.patch22
-rw-r--r--x11-plugins/wmudmount/wmudmount-1.13.ebuild43
3 files changed, 72 insertions, 1 deletions
diff --git a/x11-plugins/wmudmount/ChangeLog b/x11-plugins/wmudmount/ChangeLog
index e0d76d82f8f0..a8d13aa97843 100644
--- a/x11-plugins/wmudmount/ChangeLog
+++ b/x11-plugins/wmudmount/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/wmudmount
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmudmount/ChangeLog,v 1.13 2012/07/06 08:32:12 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmudmount/ChangeLog,v 1.14 2012/07/06 12:48:40 ssuominen Exp $
+
+*wmudmount-1.13 (06 Jul 2012)
+
+ 06 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +wmudmount-1.13.ebuild,
+ +files/wmudmount-headers.patch:
+ Version bump.
06 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -wmudmount-1.8.ebuild,
-files/wmudmount-1.8-libnotify-0.7.patch:
diff --git a/x11-plugins/wmudmount/files/wmudmount-headers.patch b/x11-plugins/wmudmount/files/wmudmount-headers.patch
new file mode 100644
index 000000000000..34fbfdf14c2a
--- /dev/null
+++ b/x11-plugins/wmudmount/files/wmudmount-headers.patch
@@ -0,0 +1,22 @@
+warning: implicit declaration of function ‘free’ and 'realloc' [-Wimplicit-function-declaration]
+
+--- askpass.c
++++ askpass.c
+@@ -23,6 +23,7 @@
+ #include <sys/resources.h>
+ #endif
+
++#include <stdlib.h> /* free */
+ #include <glib.h>
+
+ #ifdef HAVE_GNOME_KEYRING
+--- secureentry.c
++++ secureentry.c
+@@ -18,6 +18,7 @@
+ #include "config.h"
+
+ #include <unistd.h>
++#include <stdlib.h> /* free and realloc */
+ #include <string.h>
+ #ifdef HAVE_GNOME_KEYRING
+ #include <gnome-keyring-memory.h>
diff --git a/x11-plugins/wmudmount/wmudmount-1.13.ebuild b/x11-plugins/wmudmount/wmudmount-1.13.ebuild
new file mode 100644
index 000000000000..0c450c9e3151
--- /dev/null
+++ b/x11-plugins/wmudmount/wmudmount-1.13.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmudmount/wmudmount-1.13.ebuild,v 1.1 2012/07/06 12:48:40 ssuominen Exp $
+
+EAPI=4
+inherit eutils gnome2-utils
+
+DESCRIPTION="A filesystem mounter that uses udisks to handle notification and mounting"
+HOMEPAGE="http://sourceforge.net/projects/wmudmount/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome-keyring libnotify"
+
+COMMON_DEPEND=">=dev-libs/dbus-glib-0.98
+ >=dev-libs/glib-2.20
+ >=x11-libs/gtk+-2.18:2
+ x11-libs/libX11
+ gnome-keyring? ( gnome-base/libgnome-keyring )
+ libnotify? ( >=x11-libs/libnotify-0.7 )"
+RDEPEND="${COMMON_DEPEND}
+ sys-fs/udisks:0"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ || ( media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick] )"
+
+DOCS="ChangeLog"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-headers.patch
+}
+
+src_configure() {
+ econf \
+ $(use_with libnotify) \
+ $(use_with gnome-keyring)
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }