summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Crête <tester@gentoo.org>2006-10-25 02:44:28 +0000
committerOlivier Crête <tester@gentoo.org>2006-10-25 02:44:28 +0000
commitf5db46969b7d9f26e98eca1d06a38e6470d215a9 (patch)
treeb2b8bddfcf63baecc98b99bce870be8fe8831ed1 /x11-plugins
parentCleaning up ebuilds (diff)
downloadgentoo-2-f5db46969b7d9f26e98eca1d06a38e6470d215a9.tar.gz
gentoo-2-f5db46969b7d9f26e98eca1d06a38e6470d215a9.tar.bz2
gentoo-2-f5db46969b7d9f26e98eca1d06a38e6470d215a9.zip
New roll, fixes bug #152622, thanks Anarchy
(Portage version: 2.1.1-r1)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/gaim-encryption/ChangeLog8
-rw-r--r--x11-plugins/gaim-encryption/files/digest-gaim-encryption-3.0_beta6-r13
-rw-r--r--x11-plugins/gaim-encryption/gaim-encryption-3.0_beta6-r1.ebuild35
3 files changed, 45 insertions, 1 deletions
diff --git a/x11-plugins/gaim-encryption/ChangeLog b/x11-plugins/gaim-encryption/ChangeLog
index 76b5b084b7e1..a72a92f1d3a4 100644
--- a/x11-plugins/gaim-encryption/ChangeLog
+++ b/x11-plugins/gaim-encryption/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/gaim-encryption
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gaim-encryption/ChangeLog,v 1.82 2006/10/24 00:05:05 gothgirl Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gaim-encryption/ChangeLog,v 1.83 2006/10/25 02:44:28 tester Exp $
+
+*gaim-encryption-3.0_beta6-r1 (25 Oct 2006)
+
+ 25 Oct 2006; Olivier Crête <tester@gentoo.org>
+ -gaim-encryption-3.0_beta6.ebuild, +gaim-encryption-3.0_beta6-r1.ebuild:
+ New roll, fixes bug #152622, thanks Anarchy
*gaim-encryption-3.0_beta6 (24 Oct 2006)
diff --git a/x11-plugins/gaim-encryption/files/digest-gaim-encryption-3.0_beta6-r1 b/x11-plugins/gaim-encryption/files/digest-gaim-encryption-3.0_beta6-r1
new file mode 100644
index 000000000000..00255c4961c3
--- /dev/null
+++ b/x11-plugins/gaim-encryption/files/digest-gaim-encryption-3.0_beta6-r1
@@ -0,0 +1,3 @@
+MD5 807cbfc78a25e3e16ad8595522fb79cf gaim-encryption-3.0beta6.1.tar.gz 590350
+RMD160 754b5e342db58fb6023c960d75cf7da35f3373ab gaim-encryption-3.0beta6.1.tar.gz 590350
+SHA256 57078ff3e85b207737d0d9b63e52c3aad33bd9cd6a225ac404001c0fa9904d4e gaim-encryption-3.0beta6.1.tar.gz 590350
diff --git a/x11-plugins/gaim-encryption/gaim-encryption-3.0_beta6-r1.ebuild b/x11-plugins/gaim-encryption/gaim-encryption-3.0_beta6-r1.ebuild
new file mode 100644
index 000000000000..fec046258f15
--- /dev/null
+++ b/x11-plugins/gaim-encryption/gaim-encryption-3.0_beta6-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gaim-encryption/gaim-encryption-3.0_beta6-r1.ebuild,v 1.1 2006/10/25 02:44:28 tester Exp $
+
+inherit flag-o-matic debug eutils
+
+MY_PV="${PV/_beta/beta}"
+MY_P="${PN}-${MY_PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="GAIM Encryption PlugIn"
+HOMEPAGE="http://gaim-encryption.sourceforge.net/"
+SRC_URI="mirror://gentoo/${PN}/${MY_P}.1.tar.gz
+ http://dev.gentoo.org/~tester/dist/${MY_P}.1.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="nls"
+
+DEPEND=">=net-im/gaim-1.0.1
+ >=dev-libs/nss-3.11"
+
+src_compile() {
+ strip-flags
+ replace-flags -O? -O2
+ econf \
+ $(use_enable nls) || die "failed running configure"
+ emake -j1 || die "Make failed"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "Install failed"
+ dodoc CHANGELOG INSTALL NOTES README TODO VERSION WISHLIST
+}