summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2011-07-13 18:12:25 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2011-07-13 18:12:25 +0000
commit58d801dec557d2e87351ed758116f3dce8978224 (patch)
tree26e78615d3ed555b698156b12290fb4edc6c4d97 /x11-proto/glproto/glproto-1.4.14-r1.ebuild
parentUse KV_DIR instead of /lib/modules/KV_FULL/build (bug #374835) (diff)
downloadgentoo-2-58d801dec557d2e87351ed758116f3dce8978224.tar.gz
gentoo-2-58d801dec557d2e87351ed758116f3dce8978224.tar.bz2
gentoo-2-58d801dec557d2e87351ed758116f3dce8978224.zip
Add --ignore-missing to eselect opengl call, bug #374853.
(Portage version: 2.2.0_alpha43/cvs/Linux x86_64)
Diffstat (limited to 'x11-proto/glproto/glproto-1.4.14-r1.ebuild')
-rw-r--r--x11-proto/glproto/glproto-1.4.14-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-proto/glproto/glproto-1.4.14-r1.ebuild b/x11-proto/glproto/glproto-1.4.14-r1.ebuild
new file mode 100644
index 000000000000..caead6aea46c
--- /dev/null
+++ b/x11-proto/glproto/glproto-1.4.14-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-proto/glproto/glproto-1.4.14-r1.ebuild,v 1.1 2011/07/13 18:12:25 chithanh Exp $
+
+EAPI=4
+inherit xorg-2
+DESCRIPTION="X.Org GL protocol headers"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x64-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+LICENSE="SGI-B-2.0"
+IUSE=""
+
+RDEPEND=">=app-admin/eselect-opengl-1.2.3"
+DEPEND=""
+
+src_install() {
+ xorg-2_src_install
+ dynamic_libgl_install
+}
+
+pkg_postinst() {
+ xorg-2_pkg_postinst
+ eselect opengl set --ignore-missing --use-old xorg-x11
+}
+
+dynamic_libgl_install() {
+ # next section is to setup the dynamic libGL stuff
+ ebegin "Moving GL files for dynamic switching"
+ dodir /usr/$(get_libdir)/opengl/xorg-x11/include
+ local x=""
+ # glext.h added for #54984
+ for x in "${ED}"/usr/include/GL/{glxtokens.h,glxmd.h,glxproto.h}; do
+ if [[ -f ${x} || -L ${x} ]]; then
+ mv -f "${x}" "${ED}"/usr/$(get_libdir)/opengl/xorg-x11/include
+ fi
+ done
+ eend 0
+}