summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuele Giaquinta <exg@gentoo.org>2006-07-20 18:59:25 +0000
committerEmanuele Giaquinta <exg@gentoo.org>2006-07-20 18:59:25 +0000
commit5bcf9cb88e68bf16abcee5a114bce403c485bf1d (patch)
treeae2302405c43e180d4f906e88dcca810defd9004 /x11-terms
parentRemove debug. (diff)
downloadgentoo-2-5bcf9cb88e68bf16abcee5a114bce403c485bf1d.tar.gz
gentoo-2-5bcf9cb88e68bf16abcee5a114bce403c485bf1d.tar.bz2
gentoo-2-5bcf9cb88e68bf16abcee5a114bce403c485bf1d.zip
Version bump.
(Portage version: 2.1.1_pre3-r1)
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/rxvt-unicode/ChangeLog7
-rw-r--r--x11-terms/rxvt-unicode/files/digest-rxvt-unicode-7.83
-rw-r--r--x11-terms/rxvt-unicode/rxvt-unicode-7.8.ebuild79
3 files changed, 88 insertions, 1 deletions
diff --git a/x11-terms/rxvt-unicode/ChangeLog b/x11-terms/rxvt-unicode/ChangeLog
index b252c3667058..e26945e3569b 100644
--- a/x11-terms/rxvt-unicode/ChangeLog
+++ b/x11-terms/rxvt-unicode/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-terms/rxvt-unicode
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/ChangeLog,v 1.75 2006/07/15 09:28:11 killerfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/ChangeLog,v 1.76 2006/07/20 18:59:25 exg Exp $
+
+*rxvt-unicode-7.8 (20 Jul 2006)
+
+ 20 Jul 2006; Emanuele Giaquinta <exg@gentoo.org> +rxvt-unicode-7.8.ebuild:
+ Version bump.
*rxvt-unicode-7.7-r3 (15 Jul 2006)
diff --git a/x11-terms/rxvt-unicode/files/digest-rxvt-unicode-7.8 b/x11-terms/rxvt-unicode/files/digest-rxvt-unicode-7.8
new file mode 100644
index 000000000000..dcf9ae4791e7
--- /dev/null
+++ b/x11-terms/rxvt-unicode/files/digest-rxvt-unicode-7.8
@@ -0,0 +1,3 @@
+MD5 8bb2746eaa814f90d795534d67d9198a rxvt-unicode-7.8.tar.bz2 873603
+RMD160 e1fdfcda7beb3cf8e51d4088b27e646a7308a15c rxvt-unicode-7.8.tar.bz2 873603
+SHA256 f3dff7365770871651389524a3bff9b0b2c0044ef59a6a3da2039c0bf6180c9e rxvt-unicode-7.8.tar.bz2 873603
diff --git a/x11-terms/rxvt-unicode/rxvt-unicode-7.8.ebuild b/x11-terms/rxvt-unicode/rxvt-unicode-7.8.ebuild
new file mode 100644
index 000000000000..cd37ada84ba7
--- /dev/null
+++ b/x11-terms/rxvt-unicode/rxvt-unicode-7.8.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/rxvt-unicode-7.8.ebuild,v 1.1 2006/07/20 18:59:25 exg Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="rxvt clone with XFT and Unicode support"
+HOMEPAGE="http://software.schmorp.de/"
+SRC_URI="http://dist.schmorp.de/rxvt-unicode/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc-macos ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="truetype perl iso14755"
+
+# see bug #115992 for modular x deps
+RDEPEND="
+ || (
+ (
+ x11-libs/libX11
+ x11-libs/libXft
+ x11-libs/libXpm
+ x11-libs/libXrender
+ )
+ virtual/x11
+ )
+ perl? ( dev-lang/perl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ || (
+ (
+ x11-proto/xproto
+ )
+ virtual/x11
+ )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ local tdir=/usr/share/terminfo
+ sed -i -e \
+ "s~@TIC@ \(etc/rxvt\)~@TIC@ -o ${D}/${tdir} \1~" \
+ doc/Makefile.in
+ epatch "${FILESDIR}"/scrolling-one-line.patch
+}
+
+src_compile() {
+ myconf=''
+
+ use iso14755 || myconf='--disable-iso14755'
+
+ econf \
+ --enable-everything \
+ $(use_enable truetype xft) \
+ $(use_enable perl) \
+ --disable-text-blink \
+ ${myconf} \
+ || die
+
+ emake || die
+
+ sed -i \
+ -e 's/RXVT_BASENAME = "rxvt"/RXVT_BASENAME = "urxvt"/' \
+ ${S}/doc/rxvt-tabbed || die "tabs sed failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ dodoc README.FAQ Changes
+ cd "${S}"/doc
+ dodoc README* changes.txt etc/* rxvt-tabbed
+}
+
+pkg_postinst() {
+ einfo "urxvt now always uses TERM=rxvt-unicode so that the"
+ einfo "upstream-supplied terminfo files can be used."
+}
+