summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2007-06-29 03:06:11 +0000
committerSeemant Kulleen <seemant@gentoo.org>2007-06-29 03:06:11 +0000
commitec23040d7b25d563c598209996ba132e77a63f86 (patch)
tree3aa2dedb6e330948a5b2fec7dff6250ad43088b1 /x11-terms
parentVersion bump (diff)
downloadgentoo-2-ec23040d7b25d563c598209996ba132e77a63f86.tar.gz
gentoo-2-ec23040d7b25d563c598209996ba132e77a63f86.tar.bz2
gentoo-2-ec23040d7b25d563c598209996ba132e77a63f86.zip
version bump, thanks to Elias Pipping in bug #182470. Thanks to Thomas Dickey for notifying me of the new bump via email.
(Portage version: 2.1.3_rc5)
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/xterm/ChangeLog8
-rw-r--r--x11-terms/xterm/files/digest-xterm-2273
-rw-r--r--x11-terms/xterm/xterm-227.ebuild92
3 files changed, 102 insertions, 1 deletions
diff --git a/x11-terms/xterm/ChangeLog b/x11-terms/xterm/ChangeLog
index 26179a8ebe36..ffe60170357f 100644
--- a/x11-terms/xterm/ChangeLog
+++ b/x11-terms/xterm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-terms/xterm
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/xterm/ChangeLog,v 1.206 2007/06/11 02:23:13 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/xterm/ChangeLog,v 1.207 2007/06/29 03:06:11 seemant Exp $
+
+*xterm-227 (29 Jun 2007)
+
+ 29 Jun 2007; Seemant Kulleen <seemant@gentoo.org> +xterm-227.ebuild:
+ version bump, thanks to Elias Pipping in bug #182470. Thanks to Thomas
+ Dickey for notifying me of the new bump via email.
11 Jun 2007; Seemant Kulleen <seemant@gentoo.org> -xterm-222.ebuild,
-xterm-224.ebuild, xterm-225.ebuild:
diff --git a/x11-terms/xterm/files/digest-xterm-227 b/x11-terms/xterm/files/digest-xterm-227
new file mode 100644
index 000000000000..b95ccdc161b4
--- /dev/null
+++ b/x11-terms/xterm/files/digest-xterm-227
@@ -0,0 +1,3 @@
+MD5 6a2be9a63735fc8127e9098012361695 xterm-227.tgz 836997
+RMD160 e788c138434375007baf01d001411189adf3bb00 xterm-227.tgz 836997
+SHA256 37ec72c7ea051b0d0599a97e9c6f003a93e9f7c2cd3c997e285a2bbb50ca8a91 xterm-227.tgz 836997
diff --git a/x11-terms/xterm/xterm-227.ebuild b/x11-terms/xterm/xterm-227.ebuild
new file mode 100644
index 000000000000..dd1479216728
--- /dev/null
+++ b/x11-terms/xterm/xterm-227.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/xterm/xterm-227.ebuild,v 1.1 2007/06/29 03:06:11 seemant Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Terminal Emulator for X Windows"
+HOMEPAGE="http://dickey.his.com/xterm/"
+SRC_URI="ftp://invisible-island.net/${PN}/${P}.tgz"
+
+LICENSE="X11"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="truetype Xaw3d unicode toolbar paste64"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXrender
+ x11-libs/libXt
+ x11-libs/libXmu
+ x11-libs/libxkbfile
+ x11-libs/libXft
+ x11-libs/libXaw
+ unicode? ( x11-apps/luit )
+ Xaw3d? ( x11-libs/Xaw3d )
+ sys-libs/libutempter"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+pkg_setup() {
+ DEFAULTS_DIR="/usr/share/X11/app-defaults"
+}
+
+src_compile() {
+ filter-flags "-fstack-protector"
+ replace-flags "-Os" "-O2" # work around gcc-4.1.1-r[01] bugs
+
+ econf --libdir=/etc \
+ --with-x \
+ --with-utempter \
+ --disable-setuid \
+ --disable-full-tgetent \
+ --disable-imake \
+ --disable-narrowproto \
+ --enable-ansi-color \
+ --enable-256-color \
+ --enable-broken-osc \
+ --enable-broken-st \
+ --enable-load-vt-fonts \
+ --enable-i18n \
+ --enable-wide-chars \
+ --enable-doublechars \
+ --enable-warnings \
+ --enable-tcap-query \
+ --enable-logging \
+ --enable-dabbrev \
+ --with-app-defaults=${DEFAULTS_DIR} \
+ $(use_enable toolbar) \
+ $(use_enable truetype freetype) \
+ $(use_enable unicode luit) $(use_enable unicode mini-luit) \
+ $(use_with Xaw3d) \
+ $(use_enable paste64)
+
+ emake || die "emake failed."
+}
+
+# Parallel make causes File exists error and dies. Forcing -j1 for now.
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "emake install failed."
+ dodoc README{,.i18n} ctlseqs.txt
+ dohtml xterm.log.html
+
+ # Fix permissions -- it grabs them from live system, and they can
+ # be suid or sgid like they were in pre-unix98 pty or pre-utempter days,
+ # respectively (#69510).
+ # (info from Thomas Dickey) - Donnie Berkholz <spyderous@gentoo.org>
+ fperms 0755 /usr/bin/xterm
+
+ # restore the navy blue
+ sed -i "s:blue2$:blue:" ${D}${DEFAULTS_DIR}/XTerm-color
+
+ # Fix for bug #91453 at Thomas Dickey's suggestion:
+ echo "*allowWindowOps: false" >> ${D}/${DEFAULTS_DIR}/XTerm
+ echo "*allowWindowOps: false" >> ${D}/${DEFAULTS_DIR}/UXTerm
+}
+
+pkg_postinst() {
+ if use paste64 ; then
+ elog "bracketed paste mode requires the allowWindowOps resource to be true"
+ elog "which is false by default for security reasons (see bug #91453)."
+ elog "To be able to use it add 'allowWindowOps: true' to your resources"
+ fi
+}