summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTroy Dack <tad@gentoo.org>2003-06-19 11:38:29 +0000
committerTroy Dack <tad@gentoo.org>2003-06-19 11:38:29 +0000
commit5d33c3a2371661e674b4cf877c7197bb9313a76f (patch)
tree1c9e4452f514c19f5b19f4b7b6e33f470e413b64 /x11-themes/fusionx-aqua/fusionx-aqua-1.1.ebuild
parentInitial import. Bug #22784 (diff)
downloadgentoo-2-5d33c3a2371661e674b4cf877c7197bb9313a76f.tar.gz
gentoo-2-5d33c3a2371661e674b4cf877c7197bb9313a76f.tar.bz2
gentoo-2-5d33c3a2371661e674b4cf877c7197bb9313a76f.zip
Initial import. Bug #22784
Diffstat (limited to 'x11-themes/fusionx-aqua/fusionx-aqua-1.1.ebuild')
-rw-r--r--x11-themes/fusionx-aqua/fusionx-aqua-1.1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/x11-themes/fusionx-aqua/fusionx-aqua-1.1.ebuild b/x11-themes/fusionx-aqua/fusionx-aqua-1.1.ebuild
new file mode 100644
index 000000000000..c3f321b5018d
--- /dev/null
+++ b/x11-themes/fusionx-aqua/fusionx-aqua-1.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/fusionx-aqua/fusionx-aqua-1.1.ebuild,v 1.1 2003/06/19 11:38:11 tad Exp $
+
+inherit kde-base || die "Can't inherit kde-base!"
+need-kde 3.1
+
+MY_P="FusionX-Aqua-${PV}"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="The stylish \"Fusion X Aqua\" theme for KDE 3.1. This was inspired by Max Rudberg's BBX appearance theme designed for use with Apple's OS X operating system."
+HOMEPAGE="http://www.kdelook.org/content/show.php?content=5296"
+SRC_URI="http://www.kdelook.org/content/files/5296-${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+DEPEND="kde-base/kdebase"
+KEYWORDS="x86 ~ppc ~sparc ~alpha"
+
+src_compile(){
+ # nothing to compile, but don't want the eclass to try to compile anything
+ return 0
+}
+
+src_install(){
+ mkdir -p ${D}/${KDEDIR}/share/apps/kstyle
+ cp -R -f ${WORKDIR}/${MY_P}/pixmaps ${D}/${KDEDIR}/share/apps/kstyle/ || die
+ cp -R -f ${WORKDIR}/${MY_P}/themes ${D}/${KDEDIR}/share/apps/kstyle/ || die
+ mkdir -p ${D}/${KDEDIR}/share/apps/kwin
+ cp -R -f ${WORKDIR}/${MY_P}/icewm-themes ${D}/${KDEDIR}/share/apps/kwin || die
+ mkdir -p ${D}/${KDEDIR}/share/apps/kdisplay
+ cp -R -f ${WORKDIR}/${MY_P}/color-schemes ${D}/${KDEDIR}/share/apps/kdisplay || die
+ dodoc ${WORKDIR}/${MY_P}/{CREDITS,README,CHANGELOG}
+}
+
+pkg_postinst(){
+ einfo "This theme is an IceWM pixmap theme for KDE."
+ einfo ""
+ einfo "To use this theme set the following options in the"
+ einfo "KDE Control Center:"
+ einfo " o Appearance & Themes"
+ einfo " - Style = \"fusionx-aqua\""
+ einfo " - Window Decorations = \"IceWM\""
+ einfo " - Configuration [IceWM] = \"fusionX-aqua\""
+ einfo ""
+ einfo "To make the theme visible in any currently running KDE session"
+ einfo "execute the following command from a shell or the"
+ einfo "KDE \"Run Command\" dialog:"
+ einfo " kinstalltheme"
+
+} \ No newline at end of file