summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Boshell <leonardop@gentoo.org>2005-08-02 11:50:49 +0000
committerLeonardo Boshell <leonardop@gentoo.org>2005-08-02 11:50:49 +0000
commitbcf5d50846fc95e44ff703523859422b6315a50c (patch)
treebcb7b22c9f6345890e08d1126ad7d633d0f746fd /x11-themes/gtk-engines-notif2/gtk-engines-notif2-1.0-r1.ebuild
parentStable on x86 due security bug #100398 (diff)
downloadgentoo-2-bcf5d50846fc95e44ff703523859422b6315a50c.tar.gz
gentoo-2-bcf5d50846fc95e44ff703523859422b6315a50c.tar.bz2
gentoo-2-bcf5d50846fc95e44ff703523859422b6315a50c.zip
Don't inherit from gtk-engines2.eclass
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'x11-themes/gtk-engines-notif2/gtk-engines-notif2-1.0-r1.ebuild')
-rw-r--r--x11-themes/gtk-engines-notif2/gtk-engines-notif2-1.0-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-themes/gtk-engines-notif2/gtk-engines-notif2-1.0-r1.ebuild b/x11-themes/gtk-engines-notif2/gtk-engines-notif2-1.0-r1.ebuild
new file mode 100644
index 000000000000..993f092e9637
--- /dev/null
+++ b/x11-themes/gtk-engines-notif2/gtk-engines-notif2-1.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-notif2/gtk-engines-notif2-1.0-r1.ebuild,v 1.1 2005/08/02 11:50:49 leonardop Exp $
+
+inherit gnuconfig
+
+DESCRIPTION="GTK+1 Notif2 Theme Engine"
+HOMEPAGE="http://themes.freshmeat.net/projects/notif210/"
+SRC_URI="http://download.freshmeat.net/themes/notif210/notif210-1.2.tar.gz"
+KEYWORDS="~x86 ~alpha ~ppc ~amd64 ~sparc"
+LICENSE="GPL-2"
+SLOT="1"
+IUSE="static"
+
+DEPEND="=x11-libs/gtk+-1.2*"
+
+S=${WORKDIR}/notif2-${PV}
+
+src_unpack() {
+ unpack ${A}
+ if [[ ${ARCH} == "amd64" ]]; then
+ gnuconfig_update
+ fi
+}
+
+src_compile() {
+ local myconf="$(use_enable static)"
+
+ econf $myconf || die "Configuration failed"
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ einstall || die "Installation failed"
+
+ dodoc AUTHORS ChangeLog README TODO
+}