summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-10-03 22:06:07 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2010-10-03 22:06:07 +0000
commit13c508ab28d8004eeab0ad9a37ab1a668aed20b8 (patch)
treec32d1cc5a0a9a781cb9d6ce9a535a38309145f04 /x11-themes/gtk-engines/gtk-engines-2.20.2.ebuild
parentUpstream version bump; only change from 1.4.13 is updated translation (vi) (diff)
downloadgentoo-2-13c508ab28d8004eeab0ad9a37ab1a668aed20b8.tar.gz
gentoo-2-13c508ab28d8004eeab0ad9a37ab1a668aed20b8.tar.bz2
gentoo-2-13c508ab28d8004eeab0ad9a37ab1a668aed20b8.zip
Version bump. Include patches from r1. Updated translations.
(Portage version: 2.2_rc88/cvs/Linux x86_64)
Diffstat (limited to 'x11-themes/gtk-engines/gtk-engines-2.20.2.ebuild')
-rw-r--r--x11-themes/gtk-engines/gtk-engines-2.20.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-themes/gtk-engines/gtk-engines-2.20.2.ebuild b/x11-themes/gtk-engines/gtk-engines-2.20.2.ebuild
new file mode 100644
index 000000000000..4a725143728a
--- /dev/null
+++ b/x11-themes/gtk-engines/gtk-engines-2.20.2.ebuild
@@ -0,0 +1,35 @@
+
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines/gtk-engines-2.20.2.ebuild,v 1.1 2010/10/03 22:06:07 eva Exp $
+
+EAPI="3"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="GTK+2 standard engines and themes"
+HOMEPAGE="http://www.gtk.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="accessibility lua"
+
+RDEPEND=">=x11-libs/gtk+-2.12
+ lua? ( dev-lang/lua )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.31
+ >=dev-util/pkgconfig-0.9"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF} --enable-animation $(use_enable lua) $(use_with lua system-lua)"
+ use accessibility || G2CONF="${G2CONF} --disable-hc"
+}
+
+src_install() {
+ gnome2_src_install
+ find "${ED}" -name "*.la" -delete || die
+}