summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-04-14 12:07:22 +0000
committerJohannes Huber <johu@gentoo.org>2012-04-14 12:07:22 +0000
commit10ef9ac61cd906942a0b4e922072d68e0757c948 (patch)
tree9f6fd7bfcdceb19b86f760bb29c17ede57bdaf9b /x11-themes/oxygen-gtk
parentBump haskell-src-exts to 1.13.0 (diff)
downloadgentoo-2-10ef9ac61cd906942a0b4e922072d68e0757c948.tar.gz
gentoo-2-10ef9ac61cd906942a0b4e922072d68e0757c948.tar.bz2
gentoo-2-10ef9ac61cd906942a0b4e922072d68e0757c948.zip
Version bump in slot 3.
(Portage version: 2.2.0_alpha100/cvs/Linux i686)
Diffstat (limited to 'x11-themes/oxygen-gtk')
-rw-r--r--x11-themes/oxygen-gtk/ChangeLog7
-rw-r--r--x11-themes/oxygen-gtk/oxygen-gtk-1.0.3.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/x11-themes/oxygen-gtk/ChangeLog b/x11-themes/oxygen-gtk/ChangeLog
index da2ff60e1676..d7b1f1f8b5e4 100644
--- a/x11-themes/oxygen-gtk/ChangeLog
+++ b/x11-themes/oxygen-gtk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-themes/oxygen-gtk
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/oxygen-gtk/ChangeLog,v 1.31 2012/04/14 12:04:13 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/oxygen-gtk/ChangeLog,v 1.32 2012/04/14 12:07:22 johu Exp $
+
+*oxygen-gtk-1.0.3 (14 Apr 2012)
+
+ 14 Apr 2012; Johannes Huber <johu@gentoo.org> +oxygen-gtk-1.0.3.ebuild:
+ Version bump in slot 3.
*oxygen-gtk-1.2.3 (14 Apr 2012)
diff --git a/x11-themes/oxygen-gtk/oxygen-gtk-1.0.3.ebuild b/x11-themes/oxygen-gtk/oxygen-gtk-1.0.3.ebuild
new file mode 100644
index 000000000000..884dc50a47c4
--- /dev/null
+++ b/x11-themes/oxygen-gtk/oxygen-gtk-1.0.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/oxygen-gtk/oxygen-gtk-1.0.3.ebuild,v 1.3 2012/04/14 12:07:22 johu Exp $
+
+EAPI=4
+
+MY_PN=${PN}3
+MY_P=${MY_PN}-${PV}
+
+inherit cmake-utils
+
+DESCRIPTION="Official GTK+:2 port of KDE's Oxygen widget style"
+HOMEPAGE="https://projects.kde.org/projects/playground/artwork/oxygen-gtk"
+SRC_URI="mirror://kde/stable/${MY_PN}/${PV}/src/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~x86"
+SLOT="3"
+IUSE="debug doc"
+
+RDEPEND="
+ !x11-themes/oxygen-gtk:0
+ dev-libs/dbus-glib
+ dev-libs/glib
+ x11-libs/cairo
+ x11-libs/gtk+:3
+ x11-libs/libX11
+"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+DOCS=(AUTHORS README)
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ if use doc; then
+ { cd "${S}" && doxygen Doxyfile; } || die "Generating documentation failed"
+ HTML_DOCS=( "${S}/doc/html/" )
+ fi
+
+ cmake-utils_src_install
+
+ cat <<-EOF > 99oxygen-gtk3
+CONFIG_PROTECT="${EPREFIX}/usr/share/themes/oxygen-gtk/gtk-3.0"
+EOF
+ doenvd 99oxygen-gtk3
+}