summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2010-10-19 10:08:41 +0000
committerAlex Alexander <wired@gentoo.org>2010-10-19 10:08:41 +0000
commit43f79808d4d3e705955c8d24468b6a753bb49159 (patch)
treedbb5e8e8826b884ee274b0448ff886e90386273e /x11-themes/qtcurve-qt4/files
parentStable on amd64 wrt bug #341415 (diff)
downloadgentoo-2-43f79808d4d3e705955c8d24468b6a753bb49159.tar.gz
gentoo-2-43f79808d4d3e705955c8d24468b6a753bb49159.tar.bz2
gentoo-2-43f79808d4d3e705955c8d24468b6a753bb49159.zip
fixed automagic kwin dep, bug #338628. warn the user instead of dying if use windeco && ! use kde.
(Portage version: 2.2_rc89/cvs/Linux x86_64)
Diffstat (limited to 'x11-themes/qtcurve-qt4/files')
-rw-r--r--x11-themes/qtcurve-qt4/files/qtcurve-qt4_kwin_automagic_fix.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11-themes/qtcurve-qt4/files/qtcurve-qt4_kwin_automagic_fix.patch b/x11-themes/qtcurve-qt4/files/qtcurve-qt4_kwin_automagic_fix.patch
new file mode 100644
index 000000000000..ab20c5bdfa9d
--- /dev/null
+++ b/x11-themes/qtcurve-qt4/files/qtcurve-qt4_kwin_automagic_fix.patch
@@ -0,0 +1,38 @@
+diff -u -r QtCurve-KDE4-1.6.4-old/CMakeLists.txt QtCurve-KDE4-1.6.4/CMakeLists.txt
+--- QtCurve-KDE4-1.6.4-old/CMakeLists.txt 2010-10-19 12:24:18.725632000 +0300
++++ QtCurve-KDE4-1.6.4/CMakeLists.txt 2010-10-19 12:26:30.469632000 +0300
+@@ -88,14 +88,16 @@
+ add_subdirectory(colors)
+ add_subdirectory(po)
+
+- find_file(KWINGLOBALS_H kwinglobals.h ${KDE4_INCLUDES}) # kwinglobals.h is new for KDE4
++ if (QTC_KWIN)
++ find_file(KWINGLOBALS_H kwinglobals.h ${KDE4_INCLUDES}) # kwinglobals.h is new for KDE4
+
+- if (KWINGLOBALS_H)
+- add_subdirectory(kwin)
+- add_subdirectory(kwinconfig)
+- else (KWINGLOBALS_H)
+- message("** KWin headers not found - KWin decoration will not be built")
+- endif (KWINGLOBALS_H)
++ if (KWINGLOBALS_H)
++ add_subdirectory(kwin)
++ add_subdirectory(kwinconfig)
++ else (KWINGLOBALS_H)
++ message("** KWin headers not found - KWin decoration will not be built")
++ endif (KWINGLOBALS_H)
++ endif (QTC_KWIN)
+ else (NOT QTC_QT_ONLY)
+ set(CMAKE_INSTALL_PREFIX ${OLD_CMAKE_INSTALL_PREFIX})
+ add_definitions(${QT_DEFINITIONS})
+diff -u -r QtCurve-KDE4-1.6.4-old/config.h.cmake QtCurve-KDE4-1.6.4/config.h.cmake
+--- QtCurve-KDE4-1.6.4-old/config.h.cmake 2010-10-19 12:24:18.725632000 +0300
++++ QtCurve-KDE4-1.6.4/config.h.cmake 2010-10-19 12:24:42.264632000 +0300
+@@ -6,6 +6,7 @@
+ #define KDE4PREFIX "@KDE4PREFIX@"
+
+ #cmakedefine QTC_QT_ONLY
++#cmakedefine QTC_KWIN
+ #cmakedefine QTC_OLD_NVIDIA_ARROW_FIX
+ #cmakedefine QTC_STYLE_SUPPORT
+ #cmakedefine QTC_KWIN_MAX_BUTTON_HACK