summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-02-19 09:34:02 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-02-19 09:34:02 +0000
commitbe93921c32819af67d601211326a78600114062e (patch)
tree100653ddb80beb4e25bdf25418d4c5b4d3a1eab4 /x11-themes
parentVersion bump (diff)
downloadgentoo-2-be93921c32819af67d601211326a78600114062e.tar.gz
gentoo-2-be93921c32819af67d601211326a78600114062e.tar.bz2
gentoo-2-be93921c32819af67d601211326a78600114062e.zip
Version bump
(Portage version: 2.2.0_alpha85/cvs/Linux x86_64)
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/gtk-engines-qtcurve/ChangeLog8
-rw-r--r--x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-1.8.13.ebuild43
2 files changed, 50 insertions, 1 deletions
diff --git a/x11-themes/gtk-engines-qtcurve/ChangeLog b/x11-themes/gtk-engines-qtcurve/ChangeLog
index 9032678b21ef..b69be7451706 100644
--- a/x11-themes/gtk-engines-qtcurve/ChangeLog
+++ b/x11-themes/gtk-engines-qtcurve/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-themes/gtk-engines-qtcurve
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-qtcurve/ChangeLog,v 1.111 2012/02/16 19:25:53 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-qtcurve/ChangeLog,v 1.112 2012/02/19 09:34:02 hwoarang Exp $
+
+*gtk-engines-qtcurve-1.8.13 (19 Feb 2012)
+
+ 19 Feb 2012; Markos Chandras <hwoarang@gentoo.org>
+ +gtk-engines-qtcurve-1.8.13.ebuild:
+ Version bump
16 Feb 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org>
gtk-engines-qtcurve-1.8.12.ebuild:
diff --git a/x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-1.8.13.ebuild b/x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-1.8.13.ebuild
new file mode 100644
index 000000000000..f8e334f1d1a8
--- /dev/null
+++ b/x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-1.8.13.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-1.8.13.ebuild,v 1.1 2012/02/19 09:34:02 hwoarang Exp $
+
+EAPI=4
+inherit cmake-utils
+
+MY_P=${P/gtk-engines-qtcurve/QtCurve-Gtk2}
+
+DESCRIPTION="A set of widget styles for GTK2 based apps, also available for Qt4/KDE4"
+HOMEPAGE="http://www.kde-look.org/content/show.php?content=40492"
+SRC_URI="http://craigd.wikispaces.com/file/view/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="mozilla"
+
+CDEPEND="
+ x11-libs/gtk+:2
+"
+DEPEND="${CDEPEND}
+ dev-util/pkgconfig
+"
+RDEPEND="${CDEPEND}
+ mozilla? ( || (
+ >=www-client/firefox-3.0
+ >=www-client/firefox-bin-3.0
+ >=www-client/icecat-3.0
+ ) )
+"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="ChangeLog README TODO"
+
+src_configure() {
+ local mycmakeargs=(
+ "-DQTC_OLD_MOZILLA=OFF"
+ $(cmake-utils_use mozilla QTC_MODIFY_MOZILLA)
+ )
+ cmake-utils_src_configure
+}