summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2001-10-13 21:56:52 +0000
committerMartin Schlemmer <azarah@gentoo.org>2001-10-13 21:56:52 +0000
commit2b78f79813e5f54e3152de79f43052a162e0d0c1 (patch)
tree169cac0e2a5d8bed5766684608dadecd60b4c8dd /x11-wm/WindowMaker
parentremoved old version (diff)
downloadgentoo-2-2b78f79813e5f54e3152de79f43052a162e0d0c1.tar.gz
gentoo-2-2b78f79813e5f54e3152de79f43052a162e0d0c1.tar.bz2
gentoo-2-2b78f79813e5f54e3152de79f43052a162e0d0c1.zip
WindowMaker to /usr
Diffstat (limited to 'x11-wm/WindowMaker')
-rw-r--r--x11-wm/WindowMaker/WindowMaker-0.65.0.ebuild52
-rw-r--r--x11-wm/WindowMaker/WindowMaker-0.70.0.ebuild81
-rw-r--r--x11-wm/WindowMaker/files/25gnustep1
-rw-r--r--x11-wm/WindowMaker/files/digest-WindowMaker-0.70.0 (renamed from x11-wm/WindowMaker/files/digest-WindowMaker-0.65.0)2
-rwxr-xr-xx11-wm/WindowMaker/files/windowmaker5
5 files changed, 83 insertions, 58 deletions
diff --git a/x11-wm/WindowMaker/WindowMaker-0.65.0.ebuild b/x11-wm/WindowMaker/WindowMaker-0.65.0.ebuild
deleted file mode 100644
index e1a27e329fbc..000000000000
--- a/x11-wm/WindowMaker/WindowMaker-0.65.0.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/WindowMaker/WindowMaker-0.65.0.ebuild,v 1.2 2001/06/03 09:54:22 achim Exp $
-
-A="${P}.tar.gz WindowMaker-extra-0.1.tar.bz2"
-S=${WORKDIR}/${P}
-DESCRIPTION="Window Maker"
-SRC_URI="ftp://ftp.windowmaker.org/pub/source/release/${P}.tar.gz
- ftp://ftp.windowmaker.org/pub/source/release/WindowMaker-extra-0.1.tar.bz2"
-HOMEPAGE="http://www.windowmaker.org/"
-
-DEPEND="virtual/glibc virtual/x11
- >=media-libs/tiff-3.5.5
- >=media-libs/libpng-1.0.7
- >=media-libs/giflib-4.1.0
- >=x11-libs/libPropList-0.10.1"
-
-src_compile() {
- local myconf
- if [ "`use gnome`" ] ; then
- myconf="--enable-gnome"
- fi
- if [ "`use kde`" ] ; then
- myconf="$myconf --enable-kde"
- fi
- try ./configure --host=${CHOST} --prefix=/usr/X11R6 --sysconfdir=/etc/X11 \
- --with-x --enable-newstyle --enable-superfluous $myconf
- try make
- cd ../WindowMaker-extra-0.1
- try ./configure --host=${CHOST} --prefix=/usr/X11R6
- try make
-}
-
-src_install() {
- try make prefix=${D}/usr/X11R6 sysconfdir=${D}/etc/X11 install
- exeinto /usr/X11R6/bin/wm
- doexe ${FILESDIR}/windowmaker
- cp -f WindowMaker/plmenu ${D}/etc/X11/WindowMaker/WMRootMenu
- dodoc AUTHORS BUGFORUM BUGS ChangeLog COPYING* FAQ* README* NEWS TODO
-
- cd ../WindowMaker-extra-0.1
- try make prefix=${D}/usr/X11R6 install
- newdoc README README.extra
-
-
-
-}
-
-
-
-
diff --git a/x11-wm/WindowMaker/WindowMaker-0.70.0.ebuild b/x11-wm/WindowMaker/WindowMaker-0.70.0.ebuild
new file mode 100644
index 000000000000..6a8dcc875316
--- /dev/null
+++ b/x11-wm/WindowMaker/WindowMaker-0.70.0.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Window Maker"
+SRC_URI="ftp://ftp.windowmaker.org/pub/source/release/${P}.tar.gz
+ ftp://ftp.windowmaker.org/pub/source/release/WindowMaker-extra-0.1.tar.bz2"
+HOMEPAGE="http://www.windowmaker.org/"
+
+DEPEND="virtual/glibc virtual/x11
+ >=media-libs/tiff-3.5.5
+ >=media-libs/libpng-1.0.12
+ >=media-libs/giflib-4.1.0-r3
+ >=media-libs/jpeg-6b-r2
+# Replaced by WINGS
+# >=x11-libs/libPropList-0.10.1"
+
+
+src_compile() {
+
+ local myconf
+ if [ "`use gnome`" ] ; then
+ myconf="--enable-gnome"
+ fi
+ if [ "`use kde`" ] ; then
+ myconf="$myconf --enable-kde"
+ fi
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --sysconfdir=/etc/X11 \
+ --with-x --enable-newstyle \
+ --enable-superfluous \
+ GNUSTEP_LOCAL_ROOT="/usr/lib/GNUstep" \
+ $myconf || die
+
+ make || die
+
+ # WindowMaker Extra
+ cd ../WindowMaker-extra-0.1
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ GNUSTEP_LOCAL_ROOT="/usr/lib/GNUstep" || die
+
+ make || die
+}
+
+src_install() {
+
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ sysconfdir=${D}/etc/X11 \
+ GNUSTEP_LOCAL_ROOT=${D}/usr/lib/GNUstep \
+ install || die
+
+ cp -f WindowMaker/plmenu ${D}/etc/X11/WindowMaker/WMRootMenu
+
+ # Does anyone use GNUstep ? Hopefully this will be fixed when
+ # someone package GNUstep, otherwise should work just fine.
+ insinto /etc/env.d
+ doins ${FILESDIR}/25gnustep
+
+ dodoc AUTHORS BUGFORUM BUGS ChangeLog COPYING* INSTALL* FAQ* \
+ MIRRORS README* NEWS TODO
+
+ # WindowMaker Extra
+ cd ../WindowMaker-extra-0.1
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ newdoc README README.extra
+}
+
diff --git a/x11-wm/WindowMaker/files/25gnustep b/x11-wm/WindowMaker/files/25gnustep
new file mode 100644
index 000000000000..5c59167706f4
--- /dev/null
+++ b/x11-wm/WindowMaker/files/25gnustep
@@ -0,0 +1 @@
+GNUSTEP_LOCAL_ROOT=/usr/lib/GNUstep
diff --git a/x11-wm/WindowMaker/files/digest-WindowMaker-0.65.0 b/x11-wm/WindowMaker/files/digest-WindowMaker-0.70.0
index a3a23d239ce5..ac86c62e3c13 100644
--- a/x11-wm/WindowMaker/files/digest-WindowMaker-0.65.0
+++ b/x11-wm/WindowMaker/files/digest-WindowMaker-0.70.0
@@ -1,2 +1,2 @@
-MD5 b6149d460b54f4862e001fcba0ac684c WindowMaker-0.65.0.tar.gz
+MD5 ed48a3de3160a37075c9ae35ac131468 WindowMaker-0.70.0.tar.gz
MD5 e6fb381da0d207c320f58e7a1fea2a2b WindowMaker-extra-0.1.tar.bz2
diff --git a/x11-wm/WindowMaker/files/windowmaker b/x11-wm/WindowMaker/files/windowmaker
deleted file mode 100755
index 136800c1336c..000000000000
--- a/x11-wm/WindowMaker/files/windowmaker
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/sh
-if [ ! -d "~/GNUstep" ] ; then
- /usr/X11R6/bin/wmaker.inst --batch
-fi
-exec /usr/X11R6/bin/wmaker