summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-02-14 22:01:54 +0000
committerDan Armak <danarmak@gentoo.org>2002-02-14 22:01:54 +0000
commit8c826c4d0df7378d871d38d8bfc9e238c65779d1 (patch)
treed05d4214a13875d65df377837746f42a56a2ba95 /x11-wm/blackbox
parentmissing files. the patch fixes a sandbox problem. (diff)
downloadgentoo-2-8c826c4d0df7378d871d38d8bfc9e238c65779d1.tar.gz
gentoo-2-8c826c4d0df7378d871d38d8bfc9e238c65779d1.tar.bz2
gentoo-2-8c826c4d0df7378d871d38d8bfc9e238c65779d1.zip
ditto
Diffstat (limited to 'x11-wm/blackbox')
-rw-r--r--x11-wm/blackbox/blackbox-0.62.1-r1.ebuild64
-rwxr-xr-xx11-wm/blackbox/files/blackbox2
-rw-r--r--x11-wm/blackbox/files/digest-blackbox-0.62.1-r11
3 files changed, 67 insertions, 0 deletions
diff --git a/x11-wm/blackbox/blackbox-0.62.1-r1.ebuild b/x11-wm/blackbox/blackbox-0.62.1-r1.ebuild
new file mode 100644
index 000000000000..4784b65f82b4
--- /dev/null
+++ b/x11-wm/blackbox/blackbox-0.62.1-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Ben Lutgens <lamer@gentoo.org>
+# Modified by Matthew Jimenez
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/blackbox/blackbox-0.62.1-r1.ebuild,v 1.1 2002/02/14 22:01:54 danarmak Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A small, fast, full-featured window manager for X"
+SRC_URI="http://prdownloads.sourceforge.net/blackboxwm/${P}.tar.gz"
+
+# Old homepage:
+# HOMEPAGE="http://blackbox.alug.org/"
+
+# This is the new home page for blackbox now that Sean Perry has taken the
+# project over, but the page is currently non-existent
+
+HOMEPAGE="http://blackboxwm.sf.net/"
+
+
+DEPEND=">=x11-base/xfree-4.0"
+
+src_compile() {
+ local myconf
+ use nls || myconf="$myconf --disable-nls"
+
+ ./configure --build=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc/X11/blackbox \
+ $myconf || die
+ emake || die
+}
+
+src_install () {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc/X11/blackbox \
+ install || die
+
+ dodoc ChangeLog* AUTHORS LICENSE README* TODO*
+
+ exeinto /etc/X11/Sessions
+ doexe $FILESDIR/blackbox
+
+}
+
+pkg_postinst() {
+ #notify user about the new share dir
+ if [ -d /usr/share/Blackbox ]
+ then
+ echo
+ echo "!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!"
+ echo "! Blackbox no longer uses /usr/share/Blackbox as the !"
+ echo "! default share directory to contain styles and menus. !"
+ echo "! The default directory is now /usr/share/blackbox !"
+ echo "! Please move any files in /usr/share/Blackbox that you !"
+ echo "! wish to keep (personal styles and your menu) into the !"
+ echo "! new directory and modify your menu files to point all !"
+ echo "! listed paths to the new directory. !"
+ echo "! Also, be sure to update the paths in each user's !"
+ echo "! .blackboxrc file found in their home directory. !"
+ echo "!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!"
+ echo
+ fi
+}
+
diff --git a/x11-wm/blackbox/files/blackbox b/x11-wm/blackbox/files/blackbox
new file mode 100755
index 000000000000..1bb6055dec6d
--- /dev/null
+++ b/x11-wm/blackbox/files/blackbox
@@ -0,0 +1,2 @@
+#!/bin/sh
+/usr/bin/blackbox
diff --git a/x11-wm/blackbox/files/digest-blackbox-0.62.1-r1 b/x11-wm/blackbox/files/digest-blackbox-0.62.1-r1
new file mode 100644
index 000000000000..0e8940778b7c
--- /dev/null
+++ b/x11-wm/blackbox/files/digest-blackbox-0.62.1-r1
@@ -0,0 +1 @@
+MD5 a188b0bb144eb239bac98e781f1611d9 blackbox-0.62.1.tar.gz 299604