summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-08-21 16:13:28 +0000
committerMike Frysinger <vapier@gentoo.org>2011-08-21 16:13:28 +0000
commit6d87a6c6e1d336605333009c60c736df65dbb500 (patch)
treef428a16f817a8e0ba454bbebba85f18eb20ec3b1 /x11-wm/enlightenment
parentppc/ppc64 keywords dropped wrt #380085 (diff)
downloadgentoo-2-6d87a6c6e1d336605333009c60c736df65dbb500.tar.gz
gentoo-2-6d87a6c6e1d336605333009c60c736df65dbb500.tar.bz2
gentoo-2-6d87a6c6e1d336605333009c60c736df65dbb500.zip
Version bump #379793 by José Romildo Malaquias.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'x11-wm/enlightenment')
-rw-r--r--x11-wm/enlightenment/ChangeLog7
-rw-r--r--x11-wm/enlightenment/enlightenment-1.0.9.ebuild83
2 files changed, 89 insertions, 1 deletions
diff --git a/x11-wm/enlightenment/ChangeLog b/x11-wm/enlightenment/ChangeLog
index 328696ccef52..2057553c4395 100644
--- a/x11-wm/enlightenment/ChangeLog
+++ b/x11-wm/enlightenment/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/enlightenment
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/enlightenment/ChangeLog,v 1.150 2011/08/07 17:33:58 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/enlightenment/ChangeLog,v 1.151 2011/08/21 16:13:28 vapier Exp $
+
+*enlightenment-1.0.9 (21 Aug 2011)
+
+ 21 Aug 2011; Mike Frysinger <vapier@gentoo.org> +enlightenment-1.0.9.ebuild:
+ Version bump #379793 by José Romildo Malaquias.
07 Aug 2011; Raúl Porcel <armin76@gentoo.org> enlightenment-1.0.8.ebuild:
alpha/ia64/sh/sparc stable wrt #373681
diff --git a/x11-wm/enlightenment/enlightenment-1.0.9.ebuild b/x11-wm/enlightenment/enlightenment-1.0.9.ebuild
new file mode 100644
index 000000000000..cf8d4f243b42
--- /dev/null
+++ b/x11-wm/enlightenment/enlightenment-1.0.9.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/enlightenment/enlightenment-1.0.9.ebuild,v 1.1 2011/08/21 16:13:28 vapier Exp $
+
+EAPI="2"
+if [[ ${PV} == *9999 ]] ; then
+ ESVN_REPO_URI="http://svn.enlightenment.org/svn/e/trunk/E16/e"
+ inherit subversion autotools
+ SRC_URI=""
+ #KEYWORDS=""
+ S=${WORKDIR}/e16/e
+else
+ SRC_URI="mirror://sourceforge/enlightenment/e16-${PV/_/-}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+ S=${WORKDIR}/e16-${PV/_pre?}
+fi
+inherit eutils
+
+DESCRIPTION="Enlightenment Window Manager"
+HOMEPAGE="http://www.enlightenment.org/"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="dbus doc esd nls pango pulseaudio xcomposite xinerama xrandr"
+
+RDEPEND="esd? ( >=media-sound/esound-0.2.19 )
+ pulseaudio? ( media-sound/pulseaudio )
+ dbus? ( sys-apps/dbus )
+ pango? ( x11-libs/pango )
+ =media-libs/freetype-2*
+ >=media-libs/imlib2-1.3.0[X]
+ x11-libs/libSM
+ x11-libs/libICE
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXdamage
+ x11-libs/libXxf86vm
+ x11-libs/libXft
+ xrandr? ( x11-libs/libXrandr )
+ x11-libs/libXrender
+ x11-misc/xbitmaps
+ xinerama? ( x11-libs/libXinerama )
+ xcomposite? ( x11-libs/libXcomposite )
+ nls? ( virtual/libintl )
+ virtual/libiconv"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ x11-proto/xextproto
+ x11-proto/xf86vidmodeproto
+ xinerama? ( x11-proto/xineramaproto )
+ xcomposite? ( x11-proto/compositeproto )
+ x11-proto/xproto
+ nls? ( sys-devel/gettext )"
+PDEPEND="doc? ( app-doc/edox-data )"
+
+src_prepare() {
+ if [[ ! -e configure ]] ; then
+ eautopoint
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable dbus) \
+ $(use_enable pulseaudio sound-pulse) \
+ $(use_enable esd sound-esound) \
+ $(use_enable pango) \
+ $(use_enable xinerama) \
+ $(use_enable xrandr) \
+ $(use_enable xcomposite composite) \
+ --disable-docs \
+ --enable-zoom
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ rmdir "${D}"/usr/share/doc/e16 || die #294456
+ dodoc AUTHORS ChangeLog COMPLIANCE TODO sample-scripts/*
+ dohtml docs/e16.html
+}