summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2004-09-04 23:37:25 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2004-09-04 23:37:25 +0000
commita89fd05649499d4ba1e8582ea8d098dc3aa806a9 (patch)
tree2bbeb0a97880fbba03a0590ffee3c4383949809d /x11-wm/fluxbox/fluxbox-0.9.10-r1.ebuild
parentfix from bug #62751 and addition of gcc-3.4 patch (Manifest recommit) (diff)
downloadgentoo-2-a89fd05649499d4ba1e8582ea8d098dc3aa806a9.tar.gz
gentoo-2-a89fd05649499d4ba1e8582ea8d098dc3aa806a9.tar.bz2
gentoo-2-a89fd05649499d4ba1e8582ea8d098dc3aa806a9.zip
Apply the crash fix patch on every arch, since upstream like it. Remove the possibly flaky unpatched version.
Diffstat (limited to 'x11-wm/fluxbox/fluxbox-0.9.10-r1.ebuild')
-rw-r--r--x11-wm/fluxbox/fluxbox-0.9.10-r1.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/x11-wm/fluxbox/fluxbox-0.9.10-r1.ebuild b/x11-wm/fluxbox/fluxbox-0.9.10-r1.ebuild
index b4ef7105ff74..8207efb27d37 100644
--- a/x11-wm/fluxbox/fluxbox-0.9.10-r1.ebuild
+++ b/x11-wm/fluxbox/fluxbox-0.9.10-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/fluxbox/fluxbox-0.9.10-r1.ebuild,v 1.1 2004/09/03 20:12:04 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/fluxbox/fluxbox-0.9.10-r1.ebuild,v 1.2 2004/09/04 23:37:25 ciaranm Exp $
inherit eutils
@@ -29,7 +29,9 @@ KEYWORDS="~x86 ~ppc ~sparc ~amd64 ~alpha ~hppa ~ia64 ~mips ~ppc64 ~macos"
src_unpack() {
unpack ${A}
cd ${S}
- use amd64 && epatch ${FILESDIR}/${PN}-${PV}.amd64_fix.patch
+ # Fix crashy badness on amd64. Upstream sanctioned this, so we'll
+ # apply it to everyone...
+ epatch ${FILESDIR}/${PN}-${PV}.amd64_fix.patch
}
src_compile() {