summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2011-02-28 00:32:30 +0000
committerJim Ramsay <lack@gentoo.org>2011-02-28 00:32:30 +0000
commit9eb786fb4d2043116fca598c8c6d681fa4ba0488 (patch)
tree4463b7bd7a3bb29eed16f15d8134e3a89128fb29 /x11-wm/fluxbox/fluxbox-1.3.1.ebuild
parentUnmasked =sci-mathematics/octave-3.4* (diff)
downloadgentoo-2-9eb786fb4d2043116fca598c8c6d681fa4ba0488.tar.gz
gentoo-2-9eb786fb4d2043116fca598c8c6d681fa4ba0488.tar.bz2
gentoo-2-9eb786fb4d2043116fca598c8c6d681fa4ba0488.zip
Fluxbox-1.3.1 is released. Plus cleanup of a prefix patch for osx (Bug #355177)
(Portage version: 2.1.9.34/cvs/Linux i686)
Diffstat (limited to 'x11-wm/fluxbox/fluxbox-1.3.1.ebuild')
-rw-r--r--x11-wm/fluxbox/fluxbox-1.3.1.ebuild109
1 files changed, 109 insertions, 0 deletions
diff --git a/x11-wm/fluxbox/fluxbox-1.3.1.ebuild b/x11-wm/fluxbox/fluxbox-1.3.1.ebuild
new file mode 100644
index 000000000000..e5be2bab322d
--- /dev/null
+++ b/x11-wm/fluxbox/fluxbox-1.3.1.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/fluxbox/fluxbox-1.3.1.ebuild,v 1.1 2011/02/28 00:32:30 lack Exp $
+
+EAPI=4
+inherit eutils prefix
+
+IUSE="nls xinerama bidi +truetype gnome +imlib +slit +toolbar vim-syntax"
+
+DESCRIPTION="Fluxbox is an X11 window manager featuring tabs and an iconbar"
+
+SRC_URI="mirror://sourceforge/fluxbox/${P}.tar.bz2"
+HOMEPAGE="http://www.fluxbox.org"
+
+# Please note that USE="gnome" simply adds support for some gnome protocols, and
+# does not depend on external libraries. However, it does make the binary a
+# fair bit bigger, so we don't want to turn it on unless the user actually wants
+# it.
+
+RDEPEND="x11-libs/libXpm
+ x11-libs/libXrandr
+ xinerama? ( x11-libs/libXinerama )
+ x11-apps/xmessage
+ x11-libs/libXft
+ truetype? ( media-libs/freetype )
+ bidi? ( dev-libs/fribidi )
+ imlib? ( >=media-libs/imlib2-1.2.0[X] )
+ vim-syntax? ( app-vim/fluxbox-syntax )
+ !!<x11-themes/fluxbox-styles-fluxmod-20040809-r1
+ !!<=x11-misc/fluxconf-0.9.9
+ !!<=x11-misc/fbdesk-1.2.1"
+DEPEND="nls? ( sys-devel/gettext )
+ x11-proto/xextproto
+ xinerama? ( x11-proto/xineramaproto )
+ ${RDEPEND}"
+PROVIDE="virtual/blackbox"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux"
+
+src_prepare() {
+ # We need to be able to include directories rather than just plain
+ # files in menu [include] items. This patch will allow us to do clever
+ # things with style ebuilds.
+ epatch "${FILESDIR}/gentoo_style_location-1.1.x.patch"
+ eprefixify util/fluxbox-generate_menu.in
+
+ epatch "${FILESDIR}"/osx-has-otool.patch
+
+ # Add in the Gentoo -r number to fluxbox -version output.
+ if [[ "${PR}" == "r0" ]] ; then
+ suffix="gentoo"
+ else
+ suffix="gentoo-${PR}"
+ fi
+ sed -i \
+ -e "s~\(__fluxbox_version .@VERSION@\)~\1-${suffix}~" \
+ version.h.in || die "version sed failed"
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable xinerama) \
+ $(use_enable truetype xft) \
+ $(use_enable gnome) \
+ $(use_enable imlib imlib2) \
+ $(use_enable bidi fribidi ) \
+ $(use_enable slit ) \
+ $(use_enable toolbar ) \
+ --sysconfdir="${EPREFIX}"/etc/X11/${PN} \
+ --with-style="${EPREFIX}"/usr/share/fluxbox/styles/Emerge \
+ ${myconf}
+}
+
+src_compile() {
+ default
+
+ ebegin "Creating a menu file (may take a while)"
+ mkdir -p "${T}/home/.fluxbox" || die "mkdir home failed"
+ MENUFILENAME="${S}/data/menu" MENUTITLE="Fluxbox ${PV}" \
+ CHECKINIT="no. go away." HOME="${T}/home" \
+ "${S}/util/fluxbox-generate_menu" -is -ds \
+ || die "menu generation failed"
+ eend $?
+}
+
+src_install() {
+ dodir /usr/share/fluxbox
+ emake DESTDIR="${D}" STRIP="" install
+ dodoc README* AUTHORS TODO* ChangeLog NEWS
+
+ dodir /usr/share/xsessions
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}/${PN}.desktop"
+
+ exeinto /etc/X11/Sessions
+ newexe "${FILESDIR}/${PN}.xsession" fluxbox
+
+ dodir /usr/share/fluxbox/menu.d
+
+ # Styles menu framework
+ dodir /usr/share/fluxbox/menu.d/styles
+ insinto /usr/share/fluxbox/menu.d/styles
+ doins "${FILESDIR}/styles-menu-fluxbox"
+ doins "${FILESDIR}/styles-menu-commonbox"
+ doins "${FILESDIR}/styles-menu-user"
+}