summaryrefslogtreecommitdiff
path: root/x11-wm/i3
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2014-06-15 19:53:47 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2014-06-15 19:53:47 +0000
commit461047cedb904f700699a9246198ab623b33dd93 (patch)
treec279bab2b32aea2058cf66dbd0b6de9b660b49d4 /x11-wm/i3
parentadding icinga2 (diff)
downloadgentoo-2-461047cedb904f700699a9246198ab623b33dd93.tar.gz
gentoo-2-461047cedb904f700699a9246198ab623b33dd93.tar.bz2
gentoo-2-461047cedb904f700699a9246198ab623b33dd93.zip
Version bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 895192F9)
Diffstat (limited to 'x11-wm/i3')
-rw-r--r--x11-wm/i3/ChangeLog7
-rw-r--r--x11-wm/i3/i3-4.8.ebuild70
2 files changed, 76 insertions, 1 deletions
diff --git a/x11-wm/i3/ChangeLog b/x11-wm/i3/ChangeLog
index 76e6b1ab3028..db90c84958c4 100644
--- a/x11-wm/i3/ChangeLog
+++ b/x11-wm/i3/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/i3
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/i3/ChangeLog,v 1.52 2014/06/10 11:28:09 zlogene Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/i3/ChangeLog,v 1.53 2014/06/15 19:53:47 xarthisius Exp $
+
+*i3-4.8 (15 Jun 2014)
+
+ 15 Jun 2014; Kacper Kowalik <xarthisius@gentoo.org> +i3-4.8.ebuild:
+ Version bump
10 Jun 2014; Mikle Kolyada <zlogene@gentoo.org> i3-4.7.2.ebuild:
x86 stable wrt bug #499098
diff --git a/x11-wm/i3/i3-4.8.ebuild b/x11-wm/i3/i3-4.8.ebuild
new file mode 100644
index 000000000000..1a00ee383bf9
--- /dev/null
+++ b/x11-wm/i3/i3-4.8.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/i3/i3-4.8.ebuild,v 1.1 2014/06/15 19:53:47 xarthisius Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="An improved dynamic tiling window manager"
+HOMEPAGE="http://i3wm.org/"
+SRC_URI="http://i3wm.org/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+pango"
+
+CDEPEND="dev-libs/libev
+ dev-libs/libpcre
+ dev-libs/yajl
+ x11-libs/libxcb
+ x11-libs/libX11
+ x11-libs/startup-notification
+ x11-libs/xcb-util
+ x11-libs/xcb-util-cursor
+ x11-libs/xcb-util-keysyms
+ x11-libs/xcb-util-wm
+ pango? (
+ >=x11-libs/pango-1.30.0[X]
+ >=x11-libs/cairo-1.12.2[X,xcb]
+ )"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}"
+
+DOCS=( RELEASE-NOTES-${PV} )
+
+src_prepare() {
+ if ! use pango; then
+ sed -i common.mk -e '/PANGO/d' || die
+ fi
+
+ cat <<- EOF > "${T}"/i3wm
+ #!/bin/sh
+ exec /usr/bin/i3
+ EOF
+
+ epatch_user #471716
+}
+
+src_compile() {
+ emake V=1 CC="$(tc-getCC)" AR="$(tc-getAR)"
+}
+
+src_install() {
+ default
+ dohtml -r docs/*
+ doman man/*.1
+ exeinto /etc/X11/Sessions
+ doexe "${T}"/i3wm
+}
+
+pkg_postinst() {
+ einfo "There are several packages that you may find useful with ${PN} and"
+ einfo "their usage is suggested by the upstream maintainers, namely:"
+ einfo " x11-misc/dmenu"
+ einfo " x11-misc/i3status"
+ einfo " x11-misc/i3lock"
+ einfo "Please refer to their description for additional info."
+}