summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDamon Conway <kabau@gentoo.org>2001-12-14 00:18:34 +0000
committerDamon Conway <kabau@gentoo.org>2001-12-14 00:18:34 +0000
commit757ecc4c5a05c0a7e3a217ff60d1417eec334234 (patch)
tree14413479c787b0535347447187528130127076a0 /x11-wm/ion
parentCreated tcsh-6.10-r2 and removed tcsh-6.10-r1. -r2 adds system startup (diff)
downloadgentoo-2-757ecc4c5a05c0a7e3a217ff60d1417eec334234.tar.gz
gentoo-2-757ecc4c5a05c0a7e3a217ff60d1417eec334234.tar.bz2
gentoo-2-757ecc4c5a05c0a7e3a217ff60d1417eec334234.zip
Fixed /usr/share/doc location to use ${P} instead of being hard coded.
Also updated it to install config files in /etc/X11/ion instead of /etc/ion.
Diffstat (limited to 'x11-wm/ion')
-rw-r--r--x11-wm/ion/files/digest-ion-20011109-r11
-rw-r--r--x11-wm/ion/ion-20011109-r1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/x11-wm/ion/files/digest-ion-20011109-r1 b/x11-wm/ion/files/digest-ion-20011109-r1
new file mode 100644
index 000000000000..06397da9ea5a
--- /dev/null
+++ b/x11-wm/ion/files/digest-ion-20011109-r1
@@ -0,0 +1 @@
+MD5 db5400a7bb05ae74babacca60e2a2609 ion-20011109.tar.gz 180224
diff --git a/x11-wm/ion/ion-20011109-r1.ebuild b/x11-wm/ion/ion-20011109-r1.ebuild
new file mode 100644
index 000000000000..c5c5aca364a6
--- /dev/null
+++ b/x11-wm/ion/ion-20011109-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Damon Conway <kabau@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/ion/ion-20011109-r1.ebuild,v 1.1 2001/12/14 00:18:33 kabau Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A keyboard-based window manager"
+SRC_URI="http://www.students.tut.fi/~tuomov/dl/${P}.tar.gz"
+HOMEPAGE="http://www.students.tut.fi/~tuomov/ion/"
+DEPEND="virtual/glibc"
+RDEPEND="virtual/x11"
+
+src_compile() {
+ cd ${S}
+
+ # Edit system.mk
+ cp system.mk system.mk.new
+ sed -e 's:PREFIX=/usr/local:PREFIX=/usr:' \
+ -e 's:ETCDIR=$(PREFIX)/etc:ETCDIR=/etc/X11:' \
+ -e 's:$(PREFIX)/man:$(PREFIX)/share/man:' \
+ -e 's:$(PREFIX)/doc:$(PREFIX)/share/doc:' \
+ -e 's:#HAS_SYSTEM_ASPRINTF=1:HAS_SYSTEM_ASPRINTF=1:' \
+ -e 's:#INSTALL=install -c:INSTALL=install -c:' \
+ -e 's:INSTALL=install *$:#INSTALL=install:' \
+ system.mk.new > system.mk
+
+ cp Makefile Makefile.new
+ sed -e 's:$(DOCDIR)/ion:$(DOCDIR)/${P}:g' Makefile.new > Makefile
+
+ make depend || die
+ emake || die
+}
+
+src_install () {
+ make PREFIX=${D}/usr ETCDIR=${D}/etc/X11 install || die
+}
+
+pkg_postinst () {
+ einfo "Configuration documentation can be found in these places:"
+ einfo "/usr/share/doc/${P}/config.txt"
+ einfo "http://www.students.tut.fi/~tuomov/ion/resources.html"
+}