summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Boshell <leonardop@gentoo.org>2005-07-28 23:32:29 +0000
committerLeonardo Boshell <leonardop@gentoo.org>2005-07-28 23:32:29 +0000
commit04fdcd3df84011508d5cc5706175c942f0f13533 (patch)
tree4250241f39e5fb9f8d383f6da4770ce9fe5b3962 /x11-wm/metacity/metacity-2.10.3.ebuild
parentUpdated patches for last version, removed unused patches, added patch for Gen... (diff)
downloadgentoo-2-04fdcd3df84011508d5cc5706175c942f0f13533.tar.gz
gentoo-2-04fdcd3df84011508d5cc5706175c942f0f13533.tar.bz2
gentoo-2-04fdcd3df84011508d5cc5706175c942f0f13533.zip
New release: 2.10.3
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'x11-wm/metacity/metacity-2.10.3.ebuild')
-rw-r--r--x11-wm/metacity/metacity-2.10.3.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/x11-wm/metacity/metacity-2.10.3.ebuild b/x11-wm/metacity/metacity-2.10.3.ebuild
new file mode 100644
index 000000000000..4473bcbd3529
--- /dev/null
+++ b/x11-wm/metacity/metacity-2.10.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/metacity/metacity-2.10.3.ebuild,v 1.1 2005/07/28 23:32:29 leonardop Exp $
+
+inherit eutils gnome2
+
+DESCRIPTION="Gnome default windowmanager"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static xinerama"
+
+# not parallel-safe; see bug #14405
+MAKEOPTS="${MAKEOPTS} -j1"
+
+RDEPEND="virtual/x11
+ >=x11-libs/pango-1.2
+ >=x11-libs/gtk+-2.2
+ >=gnome-base/gconf-2
+ >=x11-libs/startup-notification-0.7
+ !x11-misc/expocity"
+
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.21"
+
+# Compositor is too unreliable
+G2CONF="${G2CONF} $(use_enable xinerama) $(use_enable static) \
+--disable-compositor"
+
+USE_DESTDIR="1"
+DOCS="AUTHORS ChangeLog HACKING NEWS README *.txt doc/*.txt"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Fix the logout shortcut problems, by moving the keybindings
+ # into here, from control-center, fixes bug #52034
+ epatch ${FILESDIR}/${PN}-2-logout.patch
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ einfo "Metacity & Xorg X11 with composite enabled may cause unwanted"
+ einfo "border effects"
+}