summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2003-02-05 22:54:01 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2003-02-05 22:54:01 +0000
commit3e9a7065f7e31255995e32448423996cefe16d13 (patch)
tree55c5d347e286c24935cbaad20b557dccf00eaefd /x11-wm/metacity/metacity-2.4.34.ebuild
parentadded ppc tokeywords (diff)
downloadgentoo-2-3e9a7065f7e31255995e32448423996cefe16d13.tar.gz
gentoo-2-3e9a7065f7e31255995e32448423996cefe16d13.tar.bz2
gentoo-2-3e9a7065f7e31255995e32448423996cefe16d13.zip
Gnome 2.2 final version
Diffstat (limited to 'x11-wm/metacity/metacity-2.4.34.ebuild')
-rw-r--r--x11-wm/metacity/metacity-2.4.34.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-wm/metacity/metacity-2.4.34.ebuild b/x11-wm/metacity/metacity-2.4.34.ebuild
new file mode 100644
index 000000000000..4300249f7b77
--- /dev/null
+++ b/x11-wm/metacity/metacity-2.4.34.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/metacity/metacity-2.4.34.ebuild,v 1.1 2003/02/05 22:54:01 spider Exp $
+
+inherit gnome2
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Small gtk2 WindowManager"
+HOMEPAGE="http://people.redhat.com/~hp/metacity/"
+SLOT="1"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+
+# sharp gtk dep is for a certain speed patch
+RDEPEND="virtual/x11
+ >=x11-libs/gtk+-2.2.0-r1
+ >=gnome-base/gconf-1.2
+ >=gnome-base/libglade-2
+ >=x11-libs/startup-notification-0.4"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0
+ >=dev-util/intltool-0.21"
+
+DOCS="AUTHORS ChangeLog HACKING INSTALL NEWS README"
+
+src_unpack(){
+ unpack ${A}
+ # causes ICE on ppc w/ gcc (still)
+ cd ${S}
+ use ppc && (
+ [ -z "${CC}" ] && CC=gcc
+ if [ "`${CC} -dumpversion | cut -d. -f1,2`" != "2.95" ] ; then
+ patch -p0 < ${FILESDIR}/metacity-2.4.3-ppc-gcc3.2.diff || die "patch failed"
+ fi
+ )
+}