summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-03-06 21:39:45 +0000
committerJeroen Roovers <jer@gentoo.org>2012-03-06 21:39:45 +0000
commit59b50866f165e78d947e529f75ad08d5670a2b0d (patch)
tree3e6775827ac397fab3503acc80a3948297575105 /x11-wm/musca
parentMarking epdfview-0.1.8 ppc64 for bug 400807 (diff)
downloadgentoo-2-59b50866f165e78d947e529f75ad08d5670a2b0d.tar.gz
gentoo-2-59b50866f165e78d947e529f75ad08d5670a2b0d.tar.bz2
gentoo-2-59b50866f165e78d947e529f75ad08d5670a2b0d.zip
Remove config.h patch from patch, use sed instead. Call restore_config before patching. Add sed script to remove sed subtitution that hangs waiting for pipe input now that dmenu_run does not return output.
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'x11-wm/musca')
-rw-r--r--x11-wm/musca/ChangeLog9
-rw-r--r--x11-wm/musca/files/musca-0.9.24_p20100226-dmenu-4.4.patch15
-rw-r--r--x11-wm/musca/musca-0.9.24_p20100226-r2.ebuild12
3 files changed, 17 insertions, 19 deletions
diff --git a/x11-wm/musca/ChangeLog b/x11-wm/musca/ChangeLog
index a5e940f964bc..950e7c50fd1d 100644
--- a/x11-wm/musca/ChangeLog
+++ b/x11-wm/musca/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-wm/musca
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/musca/ChangeLog,v 1.20 2012/02/17 16:00:42 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/musca/ChangeLog,v 1.21 2012/03/06 21:39:45 jer Exp $
+
+ 06 Mar 2012; Jeroen Roovers <jer@gentoo.org>
+ musca-0.9.24_p20100226-r2.ebuild,
+ files/musca-0.9.24_p20100226-dmenu-4.4.patch:
+ Remove config.h patch from patch, use sed instead. Call restore_config before
+ patching. Add sed script to remove sed subtitution that hangs waiting for
+ pipe input now that dmenu_run does not return output.
17 Feb 2012; Jeroen Roovers <jer@gentoo.org>
-musca-0.9.24_p20100226-r1.ebuild:
diff --git a/x11-wm/musca/files/musca-0.9.24_p20100226-dmenu-4.4.patch b/x11-wm/musca/files/musca-0.9.24_p20100226-dmenu-4.4.patch
index 6e5c31dc8f14..ce6bc45de73e 100644
--- a/x11-wm/musca/files/musca-0.9.24_p20100226-dmenu-4.4.patch
+++ b/x11-wm/musca/files/musca-0.9.24_p20100226-dmenu-4.4.patch
@@ -1,21 +1,6 @@
https://bugs.archlinux.org/task/25232
https://bugs.launchpad.net/musca/+bug/816890
-diff --git a/config.h b/config.h
-index f27e122..dcad60f 100644
---- a/config.h
-+++ b/config.h
-@@ -39,7 +39,7 @@ setting settings[] = {
- // optional startup file of musca commands, one per line
- { "startup", mst_str, { .s = ".musca_start" }, ".+" },
- // customize the dmenu command.
-- { "dmenu", mst_str, { .s = "sort | dmenu -i -b" }, ".+" },
-+ { "dmenu", mst_str, { .s = "-i -b" }, ".+" },
- // customize the actions of dmenu driven window/group/command menus. by default we
- // just spit commands back to musca, but you can wrap or redirect stuff. the $MUSCA
- // environment variable is set to argv[0] in setup(). -i means execute stdin.
-diff --git a/musca.c b/musca.c
-index 7f1d6a3..794bb9c 100644
--- a/musca.c
+++ b/musca.c
@@ -2162,8 +2162,16 @@ void launch(char *cmd)
diff --git a/x11-wm/musca/musca-0.9.24_p20100226-r2.ebuild b/x11-wm/musca/musca-0.9.24_p20100226-r2.ebuild
index 1b42b3e6ff6a..1c1e99397190 100644
--- a/x11-wm/musca/musca-0.9.24_p20100226-r2.ebuild
+++ b/x11-wm/musca/musca-0.9.24_p20100226-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/musca/musca-0.9.24_p20100226-r2.ebuild,v 1.1 2011/10/06 20:31:51 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/musca/musca-0.9.24_p20100226-r2.ebuild,v 1.2 2012/03/06 21:39:45 jer Exp $
EAPI="4"
@@ -26,6 +26,13 @@ RDEPEND="
"
src_prepare() {
+ restore_config config.h
+cp -av config.h{,.org}
+ sed -i config.h \
+ -e 's:"sort | dmenu -i -b":"-i -b":g' \
+ -e 's:sed.*exec.*-i::g' \
+ || die
+diff -u config.h{.org,}
epatch \
"${FILESDIR}"/${PN}-0.9.24-make.patch \
"${FILESDIR}"/${PN}-0.9.24_p20100226-dmenu-4.4.patch
@@ -37,7 +44,6 @@ src_prepare() {
fi
done
- restore_config config.h
tc-export CC
}