summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-09-03 10:48:03 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-09-03 10:48:03 +0000
commit50687d3f7e9f69b22e9ce2482724b8bb0dbf1a7a (patch)
treedb5fa00a589d89a357f7954a6fcd2dd26efd28d9 /x11-wm/openbox
parent Resolves bug #7399. Version bump. Repoman fix. Gcc3.2 patch. (diff)
downloadgentoo-2-50687d3f7e9f69b22e9ce2482724b8bb0dbf1a7a.tar.gz
gentoo-2-50687d3f7e9f69b22e9ce2482724b8bb0dbf1a7a.tar.bz2
gentoo-2-50687d3f7e9f69b22e9ce2482724b8bb0dbf1a7a.zip
new aspell unmasked as well as apps which can make use of it
Diffstat (limited to 'x11-wm/openbox')
-rw-r--r--x11-wm/openbox/openbox-2.0.0.ebuild32
1 files changed, 30 insertions, 2 deletions
diff --git a/x11-wm/openbox/openbox-2.0.0.ebuild b/x11-wm/openbox/openbox-2.0.0.ebuild
index 1a841b28a1a5..2ab9839a39ac 100644
--- a/x11-wm/openbox/openbox-2.0.0.ebuild
+++ b/x11-wm/openbox/openbox-2.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/openbox-2.0.0.ebuild,v 1.1 2002/08/17 05:29:09 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/openbox-2.0.0.ebuild,v 1.2 2002/09/03 10:48:03 seemant Exp $
inherit commonbox
@@ -15,10 +15,38 @@ KEYWORDS="x86 sparc sparc64"
MYBIN="${PN}"
mydoc="CHANGE* TODO LICENSE data/README*"
-myconf="--program-suffix=-dev --enable-xinerama"
+myconf="--enable-xinerama"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+
+ cp Makefile.am Makefile.am.orig
+ sed 's/data //' Makefile.am.orig > Makefile.am
+
+ cd ${S}/util
+ cp Makefile.am Makefile.am.orig
+ sed -e 's/bsetbg//' \
+ -e 's/bsetroot//' \
+ Makefile.am.orig > Makefile.am
+}
+
+
src_compile() {
${S}/bootstrap
+
+ commonise=""
commonbox_src_compile
}
+
+src_install() {
+
+ commonbox_src_install
+ mv ${D}/usr/bin/openbox ${D}/usr/bin/openbox-dev
+ mv ${D}/usr/share/man/man1/openbox.1.gz \
+ {D}/usr/share/man/man1/openbox-dev.1.gz
+
+}