summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2006-07-01 21:01:52 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2006-07-01 21:01:52 +0000
commitdfc1db29583adfdfe871871c6a75a206781ee40d (patch)
treea3493f71614f78d7320d98fdd000e89b274fbe35 /x11-wm/oroborus/oroborus-2.0.18.ebuild
parentPorted to modular X, stable on x86, removed old version. (diff)
downloadgentoo-2-dfc1db29583adfdfe871871c6a75a206781ee40d.tar.gz
gentoo-2-dfc1db29583adfdfe871871c6a75a206781ee40d.tar.bz2
gentoo-2-dfc1db29583adfdfe871871c6a75a206781ee40d.zip
Version bump, see bug #133623.
(Portage version: 2.1.1_pre1-r5)
Diffstat (limited to 'x11-wm/oroborus/oroborus-2.0.18.ebuild')
-rw-r--r--x11-wm/oroborus/oroborus-2.0.18.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/x11-wm/oroborus/oroborus-2.0.18.ebuild b/x11-wm/oroborus/oroborus-2.0.18.ebuild
new file mode 100644
index 000000000000..3b2f499c6f14
--- /dev/null
+++ b/x11-wm/oroborus/oroborus-2.0.18.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/oroborus/oroborus-2.0.18.ebuild,v 1.1 2006/07/01 21:01:52 nelchael Exp $
+
+DESCRIPTION="Small and fast window manager."
+HOMEPAGE="http://www.oroborus.org/"
+SRC_URI="http://www.oroborus.org/debian/dists/sid/main/source/x11/${PN}_${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="gnome"
+
+RDEPEND="|| ( ( x11-libs/libXxf86vm
+ x11-libs/libXpm
+ )
+ virtual/x11
+ )"
+DEPEND="${RDEPEND}
+ || ( ( x11-proto/xf86vidmodeproto
+ x11-proto/xextproto
+ )
+ virtual/x11
+ )"
+
+src_compile() {
+ aclocal
+ autoheader
+ automake --add-missing
+ autoconf
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc/X11/oroborus \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ || die
+ emake || die
+}
+
+src_install () {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc/X11/oroborus \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ install || die
+
+ if use gnome ; then
+ insinto /usr/share/gnome/wm-properties
+ doins ${FILESDIR}/oroborus.desktop
+ fi
+
+ dodoc README INSTALL ChangeLog TODO AUTHORS example.oroborusrc
+}