summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Wever <weeve@gentoo.org>2002-10-19 19:03:03 +0000
committerJason Wever <weeve@gentoo.org>2002-10-19 19:03:03 +0000
commit62648847a31697c156a443893937efddda525890 (patch)
tree54958282623b9a11f311c82825472b6c9bff6811 /x11-wm/ratpoison
parentFixed a typo in scrollkeeper-0.3.11.ebuild. (diff)
downloadgentoo-2-62648847a31697c156a443893937efddda525890.tar.gz
gentoo-2-62648847a31697c156a443893937efddda525890.tar.bz2
gentoo-2-62648847a31697c156a443893937efddda525890.zip
Initial addition of the Ratpoison window manager.
Diffstat (limited to 'x11-wm/ratpoison')
-rw-r--r--x11-wm/ratpoison/ChangeLog9
-rw-r--r--x11-wm/ratpoison/files/digest-ratpoison-1.1.11
-rw-r--r--x11-wm/ratpoison/ratpoison-1.1.1.ebuild43
3 files changed, 53 insertions, 0 deletions
diff --git a/x11-wm/ratpoison/ChangeLog b/x11-wm/ratpoison/ChangeLog
new file mode 100644
index 000000000000..bf374162e1f1
--- /dev/null
+++ b/x11-wm/ratpoison/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for <CATEGORY>/<PACKAGE_NAME>
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/ratpoison/ChangeLog,v 1.1 2002/10/19 19:03:03 weeve Exp $
+
+*ratpoison-1.1.1 (06 Jun 2002)
+
+ 19 Oct 2002; Jason Wever <weeve@gentoo.org> ratpoison-1.1.1.ebuild,
+ files/digest-ratpoison-1.1.1:
+ Initial import. Ebuild submitted by Jason Wever <weeve@gentoo.org>.
diff --git a/x11-wm/ratpoison/files/digest-ratpoison-1.1.1 b/x11-wm/ratpoison/files/digest-ratpoison-1.1.1
new file mode 100644
index 000000000000..874840c9bd9f
--- /dev/null
+++ b/x11-wm/ratpoison/files/digest-ratpoison-1.1.1
@@ -0,0 +1 @@
+MD5 59efd0719b6c3a9f9fcd606df95e5208 ratpoison-1.1.1.tar.gz 220424
diff --git a/x11-wm/ratpoison/ratpoison-1.1.1.ebuild b/x11-wm/ratpoison/ratpoison-1.1.1.ebuild
new file mode 100644
index 000000000000..fc08fadbdbed
--- /dev/null
+++ b/x11-wm/ratpoison/ratpoison-1.1.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/ratpoison/ratpoison-1.1.1.ebuild,v 1.1 2002/10/19 19:03:03 weeve Exp $
+
+DESCRIPTION="Ratpoison is an extremely light-weight and barebones wm modelled after screen."
+HOMEPAGE="http://ratpoison.sourceforge.net"
+SRC_URI="ftp://foo.bar.com/${P}.tar.gz"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 sparc sparc64"
+
+IUSE="X"
+
+DEPEND=">=xfree-4.2.0-r12"
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+
+ emake || die
+ #make || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ # For Makefiles that don't make proper use of DESTDIR, setting
+ # prefix is often an alternative. However if you do this, then
+ # you also need to specify mandir and infodir, since they were
+ # passed to ./configure as absolute paths (overriding the prefix
+ # setting).
+ #make \
+ # prefix=${D}/usr \
+ # mandir=${D}/usr/share/man \
+ # infodir=${D}/usr/share/info \
+ # install || die
+ # Again, verify the Makefiles! We don't want anything falling
+ # outside of ${D}.
+}