summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-05-12 12:16:49 +0000
committerAron Griffis <agriffis@gentoo.org>2004-05-12 12:16:49 +0000
commit33040e69b1fbea684bbc2fac0ebdd2fdc1a78b64 (patch)
treef1dc381cd8284e17674086489d98eaaaf505f50b /x11-wm/sawfish
parentchanged hardened PIC PIE flag logic for all lilo ebuilds (Manifest recommit) (diff)
downloadgentoo-2-33040e69b1fbea684bbc2fac0ebdd2fdc1a78b64.tar.gz
gentoo-2-33040e69b1fbea684bbc2fac0ebdd2fdc1a78b64.tar.bz2
gentoo-2-33040e69b1fbea684bbc2fac0ebdd2fdc1a78b64.zip
Restore sawfish-1.2 for gnome-1.4
Diffstat (limited to 'x11-wm/sawfish')
-rw-r--r--x11-wm/sawfish/ChangeLog5
-rw-r--r--x11-wm/sawfish/files/digest-sawfish-1.21
-rw-r--r--x11-wm/sawfish/sawfish-1.2.ebuild79
3 files changed, 84 insertions, 1 deletions
diff --git a/x11-wm/sawfish/ChangeLog b/x11-wm/sawfish/ChangeLog
index 4184c61f050e..1b19cce197a9 100644
--- a/x11-wm/sawfish/ChangeLog
+++ b/x11-wm/sawfish/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-wm/sawfish
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/ChangeLog,v 1.44 2004/05/10 20:40:34 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/ChangeLog,v 1.45 2004/05/12 12:16:49 agriffis Exp $
+
+ 11 May 2004; Aron Griffis <agriffis@gentoo.org> +sawfish-1.2.ebuild:
+ Restore sawfish-1.2 for gnome-1.4
10 May 2004; Aron Griffis <agriffis@gentoo.org> -sawfish-1.0.1-r5.ebuild,
-sawfish-1.0.1-r6.ebuild, -sawfish-1.2.ebuild, -sawfish-1.3-r1.ebuild,
diff --git a/x11-wm/sawfish/files/digest-sawfish-1.2 b/x11-wm/sawfish/files/digest-sawfish-1.2
new file mode 100644
index 000000000000..0941e220244d
--- /dev/null
+++ b/x11-wm/sawfish/files/digest-sawfish-1.2
@@ -0,0 +1 @@
+MD5 bab6b11a6e7af758606d53cb44b003ab sawfish-1.2-gtk2.tar.gz 1574246
diff --git a/x11-wm/sawfish/sawfish-1.2.ebuild b/x11-wm/sawfish/sawfish-1.2.ebuild
new file mode 100644
index 000000000000..96e20c64108e
--- /dev/null
+++ b/x11-wm/sawfish/sawfish-1.2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/sawfish-1.2.ebuild,v 1.16 2004/05/12 12:16:49 agriffis Exp $
+
+inherit base eutils
+
+IUSE="readline esd nls"
+
+MY_P="${P}-gtk2"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Extensible window manager using a Lisp-based scripting language"
+SRC_URI="mirror://sourceforge/sawmill/${MY_P}.tar.gz"
+HOMEPAGE="http://sawmill.sourceforge.net/"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 alpha -ppc"
+
+DEPEND=">=dev-util/pkgconfig-0.12.0
+ >=x11-libs/rep-gtk-0.17
+ =dev-libs/librep-0.16*
+ >=media-libs/imlib-1.9.10-r1
+ media-libs/audiofile
+ >=x11-libs/gtk+-2.0.8
+ esd? ( >=media-sound/esound-0.2.22 )
+ readline? ( >=sys-libs/readline-4.1 )
+ nls? ( sys-devel/gettext )"
+
+
+src_unpack() {
+ base_src_unpack
+
+ cd ${S}; epatch ${FILESDIR}/sawfish-1.2-fullscreen.patch
+ # Fixes gtk 2.2 being detected as 1.x
+ epatch ${FILESDIR}/sawfish-1.2-gtk+-2.2.patch
+}
+
+src_compile() {
+
+ local myconf=""
+ use esd && myconf="${myconf} --with-esd"
+ use esd || myconf="${myconf} --without-esd"
+
+ use readline && myconf="${myconf} --with-readline"
+ use readline || myconf="${myconf} --without-readline"
+
+ use nls || myconf="${myconf} --disable-linguas"
+
+ # Make sure we include freetype2 headers before freetype1 headers, else Xft2
+ # borks,
+ # <azarah@gentoo.org> (13 Dec 2002)
+ export C_INCLUDE_PATH="${C_INCLUDE_PATH}:/usr/include/freetype2"
+ export CPLUS_INCLUDE_PATH="${CPLUS_INCLUDE_PATH}:/usr/include/freetype2"
+
+ # The themer is currently broken (must have rep-gtk-0.15
+ # installed to get it compiled) - Azarah, 24 Jun 2002
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --libexecdir=/usr/lib \
+ --with-gnome-prefix=/usr \
+ --enable-gnome-widgets \
+ --enable-capplet \
+ --disable-themer \
+ --with-gdk-pixbuf \
+ --with-audiofile \
+ ${myconf} || die
+
+ # DO NOT USE "emake" !!! - Azarah, 24 Jun 2002
+ MAKEOPTS=-j1 make || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS BUGS COPYING ChangeLog DOC FAQ NEWS README THANKS TODO
+
+ # Add to Gnome CC's Window Manager list
+ insinto /usr/share/gnome/wm-properties
+ doins ${FILESDIR}/Sawfish.desktop
+}