summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarald van Dijk <truedfx@gentoo.org>2010-05-31 20:05:17 +0000
committerHarald van Dijk <truedfx@gentoo.org>2010-05-31 20:05:17 +0000
commitdb1e57d927abda8aeb29dc9cb993601971ceb8ae (patch)
tree048d7ef1aa3fa984ebe691d560854eaa9046bc9e /x11-wm/sawfish
parentx86 stable wrt bug #320711 (diff)
downloadgentoo-2-db1e57d927abda8aeb29dc9cb993601971ceb8ae.tar.gz
gentoo-2-db1e57d927abda8aeb29dc9cb993601971ceb8ae.tar.bz2
gentoo-2-db1e57d927abda8aeb29dc9cb993601971ceb8ae.zip
Version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'x11-wm/sawfish')
-rw-r--r--x11-wm/sawfish/ChangeLog8
-rw-r--r--x11-wm/sawfish/files/sawfish-1.6.3-prompt.patch22
-rw-r--r--x11-wm/sawfish/sawfish-1.6.3.ebuild76
3 files changed, 105 insertions, 1 deletions
diff --git a/x11-wm/sawfish/ChangeLog b/x11-wm/sawfish/ChangeLog
index 44835cc27081..ee1f846d54e2 100644
--- a/x11-wm/sawfish/ChangeLog
+++ b/x11-wm/sawfish/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-wm/sawfish
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/ChangeLog,v 1.93 2010/03/28 19:43:37 truedfx Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/ChangeLog,v 1.94 2010/05/31 20:05:17 truedfx Exp $
+
+*sawfish-1.6.3 (31 May 2010)
+
+ 31 May 2010; Harald van Dijk <truedfx@gentoo.org> +sawfish-1.6.3.ebuild,
+ +files/sawfish-1.6.3-prompt.patch:
+ Version bump
*sawfish-1.6.2 (28 Mar 2010)
diff --git a/x11-wm/sawfish/files/sawfish-1.6.3-prompt.patch b/x11-wm/sawfish/files/sawfish-1.6.3-prompt.patch
new file mode 100644
index 000000000000..7666746ab770
--- /dev/null
+++ b/x11-wm/sawfish/files/sawfish-1.6.3-prompt.patch
@@ -0,0 +1,22 @@
+--- sawfish/lisp/sawfish/wm/util/prompt.jl
++++ sawfish/lisp/sawfish/wm/util/prompt.jl
+@@ -121,10 +121,15 @@
+ ;; Compilation hack: ensure that the compiler doesn't complain when
+ ;; these are treated like functions and passed values.
+ (eval-when-compile
+- (setq prompt-completion-fun (lambda (#!rest) nil)
+- prompt-validation-fun (lambda (#!rest) nil)
+- prompt-abbrev-fun (lambda (#!rest) nil)
+- prompt-display-fun (lambda (#!rest) nil)))
++ (progn
++ (defvar prompt-completion-fun nil)
++ (defvar prompt-validation-fun nil)
++ (defvar prompt-abbrev-fun nil)
++ (defvar prompt-display-fun nil)
++ (setq prompt-completion-fun (lambda (#!rest) nil)
++ prompt-validation-fun (lambda (#!rest) nil)
++ prompt-abbrev-fun (lambda (#!rest) nil)
++ prompt-display-fun (lambda (#!rest) nil))))
+
+
+ ;; From merlin
diff --git a/x11-wm/sawfish/sawfish-1.6.3.ebuild b/x11-wm/sawfish/sawfish-1.6.3.ebuild
new file mode 100644
index 000000000000..8238843ed046
--- /dev/null
+++ b/x11-wm/sawfish/sawfish-1.6.3.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/sawfish-1.6.3.ebuild,v 1.1 2010/05/31 20:05:17 truedfx Exp $
+
+# detect cvs snapshots; fex. 1.3_p20040120
+[[ $PV == *_p[0-9][0-9][0-9][0-9][0-9][0-9][0-9][0-9] ]]
+(( snapshot = !$? ))
+
+if (( snapshot )); then
+ inherit eutils autotools
+else
+ inherit eutils
+fi
+
+DESCRIPTION="Extensible window manager using a Lisp-based scripting language"
+HOMEPAGE="http://sawfish.wikia.com/"
+if (( snapshot )); then
+ SRC_URI="mirror://gentoo/${P/_p/.}.tar.bz2"
+else
+ SRC_URI="http://download.tuxfamily.org/sawfish/sawfish/${P}.tar.bz2"
+fi
+
+LICENSE="GPL-2 Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="nls xinerama"
+
+RDEPEND=">=dev-libs/librep-0.90.5
+ >=x11-libs/rep-gtk-0.90.2
+ >=x11-libs/pango-1.8.0
+ >=x11-libs/gtk+-2.12.0
+ nls? ( sys-devel/gettext )
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0"
+
+if (( snapshot )); then
+ S="${WORKDIR}/${PN}"
+fi
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-prompt.patch
+
+ if (( snapshot )); then
+ eautoreconf
+ fi
+}
+
+src_compile() {
+ set -- \
+ $(use_with xinerama) \
+ --with-gdk-pixbuf
+
+ if ! use nls; then
+ # Use a space because configure script reads --enable-linguas="" as
+ # "install everything"
+ # Don't use --disable-linguas, because that means --enable-linguas="no",
+ # which means "install Norwegian translations"
+ set -- "$@" --enable-linguas=" "
+ elif [[ "${LINGUAS+set}" == "set" ]]; then
+ strip-linguas -i po
+ set -- "$@" --enable-linguas=" ${LINGUAS} "
+ else
+ set -- "$@" --enable-linguas=""
+ fi
+
+ econf "$@" || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog DOC FAQ NEWS OPTIONS README README.IMPORTANT TODO
+}