summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2002-04-25 15:12:16 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2002-04-25 15:12:16 +0000
commit8a694251560955540f14a20da7d3f0333863b5d7 (patch)
tree9a374dce7bde31902a18c4090315439e21061cce /x11-wm/xfce/xfce-3.8.16.ebuild
parentfixo #3 (diff)
downloadgentoo-2-8a694251560955540f14a20da7d3f0333863b5d7.tar.gz
gentoo-2-8a694251560955540f14a20da7d3f0333863b5d7.tar.bz2
gentoo-2-8a694251560955540f14a20da7d3f0333863b5d7.zip
New version.
Diffstat (limited to 'x11-wm/xfce/xfce-3.8.16.ebuild')
-rw-r--r--x11-wm/xfce/xfce-3.8.16.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/x11-wm/xfce/xfce-3.8.16.ebuild b/x11-wm/xfce/xfce-3.8.16.ebuild
new file mode 100644
index 000000000000..8117d2ce7a04
--- /dev/null
+++ b/x11-wm/xfce/xfce-3.8.16.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Ben Lutgens <ben@sistina.com>
+# /space/gentoo/cvsroot/gentoo-x86/x11-wm/xfce/xfce-3.8.11-r2.ebuild,v 1.1 2002/03/12 12:54:06 seemant Exp
+
+S=${WORKDIR}/${P}
+DESCRIPTION="XFce is a lightweight desktop environment for various UNIX systems."
+SRC_URI="http://prdownloads.sourceforge.net/xfce/${P}.tar.gz"
+HOMEPAGE="http://www.xfce.org/"
+
+DEPEND="virtual/x11
+ >=x11-libs/gtk+-1.2.10-r4
+ gnome? ( dev-libs/libxml2 )
+ gtk? ( >=media-libs/gdk-pixbuf-0.11.0-r1 )
+ arts? ( kde-base/kdelibs )
+ nls? ( sys-devel/gettext )"
+
+ use gtk || DEPEND="${DEPEND} >=media-libs/imlib-1.9.10-r1"
+RDEPEND=""
+
+src_compile() {
+ local myconf
+
+ use gtk && myconf="--enable-imlib=no --enable-gdk-pixbuf=/usr"
+
+ if [ "`use gnome`" ]
+ then
+ myconf="${myconf} --enable-gdm"
+ myconf="${myconf} --enable-libxml2"
+ fi
+
+ use nls || myconf="${myconf} --disable-nls"
+ use arts && myconf="${myconf} --enable-arts"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --with-data-dir=/usr/share/xfce \
+ --with-conf-dir=/etc/xfce \
+ --enable-xft \
+ --with-locale-dir=/usr/share/locale \
+ ${myconf} || die
+
+ cd docs
+ cp Makefile Makefile.orig
+ sed "s:/usr/share/xfce:/usr/share/doc/${PF}:" Makefile.orig > Makefile
+ cd ..
+
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc ChangeLog* AUTHORS LICENSE README* TODO*
+ dodir /etc/skel/.xfce
+
+ exeinto /etc/X11/Sessions
+ doexe $FILESDIR/xfce
+}