summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Teaford Cowan <bcowan@gentoo.org>2002-12-09 03:56:28 +0000
committerBrad Teaford Cowan <bcowan@gentoo.org>2002-12-09 03:56:28 +0000
commit9e7aade562ea64e1808b3cd0bf42cf38173cdefa (patch)
tree133adb1cced27a260c2708d4304be8b25b065de8 /x11-wm/xfce/xfce-3.8.18-r1.ebuild
parent Version bump. Lots of fluid bug fixes. Also fixes for compatibility (diff)
downloadgentoo-2-9e7aade562ea64e1808b3cd0bf42cf38173cdefa.tar.gz
gentoo-2-9e7aade562ea64e1808b3cd0bf42cf38173cdefa.tar.bz2
gentoo-2-9e7aade562ea64e1808b3cd0bf42cf38173cdefa.zip
added taskbar support, closes bug #11788
Diffstat (limited to 'x11-wm/xfce/xfce-3.8.18-r1.ebuild')
-rw-r--r--x11-wm/xfce/xfce-3.8.18-r1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/x11-wm/xfce/xfce-3.8.18-r1.ebuild b/x11-wm/xfce/xfce-3.8.18-r1.ebuild
new file mode 100644
index 000000000000..e797783dfbf3
--- /dev/null
+++ b/x11-wm/xfce/xfce-3.8.18-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/xfce/xfce-3.8.18-r1.ebuild,v 1.1 2002/12/09 03:56:28 bcowan Exp $
+
+IUSE="arts gtk gnome nls"
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="XFce is a lightweight desktop environment for various UNIX systems."
+SRC_URI="mirror://sourceforge/xfce/${P}.tar.gz"
+HOMEPAGE="http://www.xfce.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="virtual/x11
+ =x11-libs/gtk+-1.2*
+ gnome? ( dev-libs/libxml2 )
+ gtk? ( >=media-libs/gdk-pixbuf-0.11.0-r1 >=media-libs/imlib-1.9.10-r1 )
+ arts? ( kde-base/arts )"
+
+RDEPEND="nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf
+
+ use gtk && myconf="--enable-imlib=no --enable-gdk-pixbuf=/usr"
+
+ use gnome && myconf="${myconf} --enable-gdm --enable-libxml2"
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ use arts && myconf="${myconf} --enable-arts"
+
+ econf \
+ --enable-xft \
+ --enable-taskbar \
+ ${myconf} || die
+
+ cd docs
+ cp Makefile Makefile.orig
+ sed "s:/usr/share/xfce:/usr/share/doc/${PF}:" Makefile.orig > Makefile
+ cd ..
+
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodir /etc/skel/.xfce
+
+ exeinto /etc/X11/Sessions
+ doexe $FILESDIR/xfce
+
+ dodoc ChangeLog* AUTHORS LICENSE README* TODO*
+}