summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-08-30 16:33:48 +0000
committerMamoru Komachi <usata@gentoo.org>2004-08-30 16:33:48 +0000
commit961f6bf39926c5308a48761b9d93f56fff72f004 (patch)
tree3acc33e8c42f26899583bc12eb01f8462df8ba65 /x11-wm/xpde/xpde-0.5.1.ebuild
parentAdded to ~ppc (diff)
downloadgentoo-2-961f6bf39926c5308a48761b9d93f56fff72f004.tar.gz
gentoo-2-961f6bf39926c5308a48761b9d93f56fff72f004.tar.bz2
gentoo-2-961f6bf39926c5308a48761b9d93f56fff72f004.zip
Version bumped. Thanks to Boris Wachtmeister <sirro@nurfuerspam.de>, closing bug #45638.
Diffstat (limited to 'x11-wm/xpde/xpde-0.5.1.ebuild')
-rw-r--r--x11-wm/xpde/xpde-0.5.1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/x11-wm/xpde/xpde-0.5.1.ebuild b/x11-wm/xpde/xpde-0.5.1.ebuild
new file mode 100644
index 000000000000..b43d0f8c09b4
--- /dev/null
+++ b/x11-wm/xpde/xpde-0.5.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/xpde/xpde-0.5.1.ebuild,v 1.1 2004/08/30 16:33:48 usata Exp $
+
+inherit eutils
+
+DESCRIPTION="A Desktop Environment modelled after the O/S from Redmond, WA"
+HOMEPAGE="http://www.xpde.com"
+SRC_URI="http://www.xpde.com/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 -*"
+IUSE=""
+
+DEPEND="virtual/x11"
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gentoo.diff
+}
+
+src_compile() {
+ einfo
+ einfo "This is a binary-only package (sadly)"
+ einfo "No files to compile."
+ einfo
+}
+
+src_install() {
+ cd ${S}/bin
+
+ dodir /opt/xpde/bin/applets
+
+ dodir /opt/xpde/share
+ cp -a defaultdesktop ${D}/opt/xpde/share
+
+ exeinto /opt/xpde/bin
+ doexe *.so* startxpde xpde
+
+ exeinto /opt/xpde/bin/applets
+ doexe applets/desktop_properties
+
+ exeinto /etc/X11/Sessions
+ newexe startxpde ${P}
+}