summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-05-28 15:41:04 +0000
committerMike Frysinger <vapier@gentoo.org>2004-05-28 15:41:04 +0000
commit05554055fef72aa90b009568a2082f6e55b7c10e (patch)
tree168c5ec2e07bb7721bd80b5446f565e9dd5ba577 /x11-wm
parentUpstream requested minor changes (Manifest recommit) (diff)
downloadgentoo-2-05554055fef72aa90b009568a2082f6e55b7c10e.tar.gz
gentoo-2-05554055fef72aa90b009568a2082f6e55b7c10e.tar.bz2
gentoo-2-05554055fef72aa90b009568a2082f6e55b7c10e.zip
you fools need to learn how to inherit eutils for epatch
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/aewm++-goodies/aewm++-goodies-1.0.ebuild9
-rw-r--r--x11-wm/ion/ion-20020207-r1.ebuild12
-rw-r--r--x11-wm/openbox/openbox-3.2-r1.ebuild16
3 files changed, 21 insertions, 16 deletions
diff --git a/x11-wm/aewm++-goodies/aewm++-goodies-1.0.ebuild b/x11-wm/aewm++-goodies/aewm++-goodies-1.0.ebuild
index a49c461b4088..048850fadec6 100644
--- a/x11-wm/aewm++-goodies/aewm++-goodies-1.0.ebuild
+++ b/x11-wm/aewm++-goodies/aewm++-goodies-1.0.ebuild
@@ -1,15 +1,18 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/aewm++-goodies/aewm++-goodies-1.0.ebuild,v 1.5 2004/05/07 21:09:18 tseng Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/aewm++-goodies/aewm++-goodies-1.0.ebuild,v 1.6 2004/05/28 15:41:04 vapier Exp $
-IUSE=""
+inherit eutils
-DESCRIPTION="Goodies for aewm++."
+DESCRIPTION="Goodies for aewm++"
HOMEPAGE="http://sapphire.sourceforge.net/"
SRC_URI="mirror://sourceforge/sapphire/${P/-/_}.tar.bz2"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ~amd64"
+IUSE=""
+
DEPEND="virtual/x11"
S="${WORKDIR}/${PN/-/_}"
diff --git a/x11-wm/ion/ion-20020207-r1.ebuild b/x11-wm/ion/ion-20020207-r1.ebuild
index fa5050a188d8..298f330f00d2 100644
--- a/x11-wm/ion/ion-20020207-r1.ebuild
+++ b/x11-wm/ion/ion-20020207-r1.ebuild
@@ -1,14 +1,17 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/ion/ion-20020207-r1.ebuild,v 1.8 2004/05/07 21:16:21 tseng Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/ion/ion-20020207-r1.ebuild,v 1.9 2004/05/28 15:41:04 vapier Exp $
+
+inherit eutils
-SRC_URI="http://www.students.tut.fi/~tuomov/dl/${P}.tar.gz"
DESCRIPTION="A keyboard-based window manager"
HOMEPAGE="http://www.students.tut.fi/~tuomov/ion/"
-IUSE=""
-SLOT="0"
+SRC_URI="http://www.students.tut.fi/~tuomov/dl/${P}.tar.gz"
+
LICENSE="Clarified-Artistic"
+SLOT="0"
KEYWORDS="x86 ppc sparc"
+IUSE=""
DEPEND="virtual/x11"
@@ -18,7 +21,6 @@ src_unpack() {
epatch ${FILESDIR}/${P}-gentoo.diff
}
-
src_compile() {
# Edit system.mk
cp system.mk system.mk.new
diff --git a/x11-wm/openbox/openbox-3.2-r1.ebuild b/x11-wm/openbox/openbox-3.2-r1.ebuild
index 91a73e305a68..8ffd305c80e4 100644
--- a/x11-wm/openbox/openbox-3.2-r1.ebuild
+++ b/x11-wm/openbox/openbox-3.2-r1.ebuild
@@ -1,16 +1,19 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/openbox-3.2-r1.ebuild,v 1.5 2004/05/11 00:17:41 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/openbox-3.2-r1.ebuild,v 1.6 2004/05/28 15:41:04 vapier Exp $
+
+inherit eutils
S=${WORKDIR}/${P/_/-}
DESCRIPTION="Openbox is a standards compliant, fast, light-weight, extensible window manager."
-
+HOMEPAGE="http://icculus.org/openbox/"
SRC_URI="http://icculus.org/openbox/releases/${P/_/-}.tar.gz
- mirror://gentoo/ob-themes-usability.tar.bz2"
+ mirror://gentoo/ob-themes-usability.tar.bz2"
-HOMEPAGE="http://icculus.org/openbox/"
-IUSE="nls"
+LICENSE="GPL-2"
SLOT="3"
+KEYWORDS="x86 sparc ~alpha ~ppc ~amd64"
+IUSE="nls"
RDEPEND="virtual/xft
virtual/x11
@@ -20,9 +23,6 @@ RDEPEND="virtual/xft
DEPEND="${RDEPEND}
dev-util/pkgconfig"
-LICENSE="GPL-2"
-KEYWORDS="x86 sparc ~alpha ~ppc ~amd64"
-
src_unpack() {
unpack ${A}
cd ${S}