summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-04-30 11:03:01 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-04-30 11:03:01 +0000
commit18fd924140c7f9fdebf5f485bce6ea418c1355fd (patch)
tree33745d27b1e9ba457e680fb6becb21190cb7a505 /x11-wm
parentman pages LFH fix (diff)
downloadgentoo-2-18fd924140c7f9fdebf5f485bce6ea418c1355fd.tar.gz
gentoo-2-18fd924140c7f9fdebf5f485bce6ea418c1355fd.tar.bz2
gentoo-2-18fd924140c7f9fdebf5f485bce6ea418c1355fd.zip
man pages made LFH compliant
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/blackbox/blackbox-0.62.1-r2.ebuild79
1 files changed, 37 insertions, 42 deletions
diff --git a/x11-wm/blackbox/blackbox-0.62.1-r2.ebuild b/x11-wm/blackbox/blackbox-0.62.1-r2.ebuild
index 9627410c5a6b..b42fb295097a 100644
--- a/x11-wm/blackbox/blackbox-0.62.1-r2.ebuild
+++ b/x11-wm/blackbox/blackbox-0.62.1-r2.ebuild
@@ -2,18 +2,11 @@
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Ben Lutgens <lamer@gentoo.org>
# Modified by Matthew Jimenez
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/blackbox/blackbox-0.62.1-r2.ebuild,v 1.3 2002/04/13 00:47:14 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/blackbox/blackbox-0.62.1-r2.ebuild,v 1.4 2002/04/30 11:03:01 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="A small, fast, full-featured window manager for X"
SRC_URI="http://prdownloads.sourceforge.net/blackboxwm/${P}.tar.gz"
-
-# Old homepage:
-# HOMEPAGE="http://blackbox.alug.org/"
-
-# This is the new home page for blackbox now that Sean Perry has taken the
-# project over, but the page is currently non-existent
-
HOMEPAGE="http://blackboxwm.sf.net/"
DEPEND="virtual/x11"
@@ -24,46 +17,48 @@ RDEPEND="${DEPEND}
PROVIDE="virtual/blackbox"
src_compile() {
- local myconf
- use nls || myconf="${myconf} --disable-nls"
-
- ./configure \
- --build=${CHOST} \
- --prefix=/usr \
- --sysconfdir=/etc/X11/blackbox \
- ${myconf} || die
- emake || die
+ local myconf
+ use nls || myconf="${myconf} --disable-nls"
+
+ myconf="${myconf} --sysconfdir=/etc/X11/blackbox"
+
+ econf ${myconf} || die
+
+ emake || die
}
src_install () {
- make prefix=${D}/usr \
- sysconfdir=${D}/etc/X11/blackbox \
- install || die
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ datadir=${D}/usr/share \
+ sysconfdir=${D}/etc/X11/blackbox \
+ install || die
- dodoc ChangeLog* AUTHORS LICENSE README* TODO*
-
- exeinto /etc/X11/Sessions
- doexe $FILESDIR/blackbox
-
+ dodoc ChangeLog* AUTHORS LICENSE README* TODO*
+
+ exeinto /etc/X11/Sessions
+ doexe $FILESDIR/blackbox
+
}
pkg_postinst() {
- #notify user about the new share dir
- if [ -d /usr/share/Blackbox ]
- then
- einfo
- einfo "!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!"
- einfo "! Blackbox no longer uses /usr/share/Blackbox as the !"
- einfo "! default share directory to contain styles and menus. !"
- einfo "! The default directory is now /usr/share/blackbox !"
- einfo "! Please move any files in /usr/share/Blackbox that you !"
- einfo "! wish to keep (personal styles and your menu) into the !"
- einfo "! new directory and modify your menu files to point all !"
- einfo "! listed paths to the new directory. !"
- einfo "! Also, be sure to update the paths in each user's !"
- einfo "! .blackboxrc file found in their home directory. !"
- einfo "!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!"
- einfo
- fi
+ #notify user about the new share dir
+ if [ -d /usr/share/Blackbox ]
+ then
+ einfo
+ einfo "!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!"
+ einfo "! Blackbox no longer uses /usr/share/Blackbox as the !"
+ einfo "! default share directory to contain styles and menus. !"
+ einfo "! The default directory is now /usr/share/blackbox !"
+ einfo "! Please move any files in /usr/share/Blackbox that you !"
+ einfo "! wish to keep (personal styles and your menu) into the !"
+ einfo "! new directory and modify your menu files to point all !"
+ einfo "! listed paths to the new directory. !"
+ einfo "! Also, be sure to update the paths in each user's !"
+ einfo "! .blackboxrc file found in their home directory. !"
+ einfo "!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!"
+ einfo
+ fi
}