summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2006-09-28 01:48:12 +0000
committerHanno Böck <hanno@gentoo.org>2006-09-28 01:48:12 +0000
commit29a62b90c4be3fade759437bc7bf48997326cde9 (patch)
tree253cfe04f0c2c2765eadee5ab02dfc79b2cf091d /x11-wm
parentVersion bump. (diff)
downloadgentoo-2-29a62b90c4be3fade759437bc7bf48997326cde9.tar.gz
gentoo-2-29a62b90c4be3fade759437bc7bf48997326cde9.tar.bz2
gentoo-2-29a62b90c4be3fade759437bc7bf48997326cde9.zip
compiz bump
(Portage version: 2.1.2_pre1-r4)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/compiz/ChangeLog9
-rw-r--r--x11-wm/compiz/compiz-0.0.13_pre20060928.ebuild53
-rwxr-xr-xx11-wm/compiz/files/compiz-aiglx4
-rwxr-xr-xx11-wm/compiz/files/compiz-nvidia5
-rwxr-xr-xx11-wm/compiz/files/compiz-xgl5
-rw-r--r--x11-wm/compiz/files/digest-compiz-0.0.13_pre200609283
6 files changed, 76 insertions, 3 deletions
diff --git a/x11-wm/compiz/ChangeLog b/x11-wm/compiz/ChangeLog
index 3d16e1f7ad8e..b02f71bfddab 100644
--- a/x11-wm/compiz/ChangeLog
+++ b/x11-wm/compiz/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-wm/compiz
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/compiz/ChangeLog,v 1.3 2006/09/21 14:22:13 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/compiz/ChangeLog,v 1.4 2006/09/28 01:48:12 hanno Exp $
+
+*compiz-0.0.13_pre20060928 (28 Sep 2006)
+
+ 28 Sep 2006; Hanno Boeck <hanno@gentoo.org> files/compiz-aiglx,
+ +files/compiz-nvidia, +files/compiz-xgl,
+ +compiz-0.0.13_pre20060928.ebuild:
+ Version bump, new scripts for xgl and nvidia, misc fixes.
21 Sep 2006; Hanno Boeck <hanno@gentoo.org>
compiz-0.0.13_pre20060921.ebuild:
diff --git a/x11-wm/compiz/compiz-0.0.13_pre20060928.ebuild b/x11-wm/compiz/compiz-0.0.13_pre20060928.ebuild
new file mode 100644
index 000000000000..0c76e517a1bb
--- /dev/null
+++ b/x11-wm/compiz/compiz-0.0.13_pre20060928.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/compiz/compiz-0.0.13_pre20060928.ebuild,v 1.1 2006/09/28 01:48:12 hanno Exp $
+
+inherit eutils autotools
+
+SRC_URI="http://www.schokokeks.org/~hanno/snapshots/${PN}-${PV##*_pre}.tar.bz2"
+
+S=${WORKDIR}/${PN}
+
+DESCRIPTION="compiz 3D composite- and windowmanager"
+HOMEPAGE="http://en.opensuse.org/Compiz"
+LICENSE="X11"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="dbus svg"
+
+DEPEND=">=media-libs/mesa-6.5.1-r1
+ >=media-libs/glitz-0.5.6
+ >=x11-base/xorg-server-1.1.1-r1
+ x11-libs/libXdamage
+ x11-libs/libXrandr
+ x11-libs/libXcomposite
+ media-libs/libpng
+ x11-libs/libwnck
+ gnome-base/control-center
+ svg? ( gnome-base/librsvg )
+ dbus? ( sys-apps/dbus )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/06-glfinish.patch
+}
+
+src_compile() {
+ eautoreconf || die
+ glib-gettextize --copy --force || die
+
+ econf --enable-gtk \
+ --enable-gnome \
+ --enable-gconf \
+ --disable-kde \
+ `use_enable svg librsvg` \
+ `use_enable dbus` || die
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dobin ${FILESDIR}/compiz-{aiglx,xgl,nvidia}
+}
diff --git a/x11-wm/compiz/files/compiz-aiglx b/x11-wm/compiz/files/compiz-aiglx
index f0a95bde9a1b..01f985ca9d28 100755
--- a/x11-wm/compiz/files/compiz-aiglx
+++ b/x11-wm/compiz/files/compiz-aiglx
@@ -1,5 +1,5 @@
# Start window decorator
-gnome-window-decorator --replace &
+gtk-window-decorator --replace &
# Start compiz
-LIBGL_ALWAYS_INDIRECT=1 compiz --replace --use-cow --indirect-rendering --strict-binding gconf move resize minimize place decoration wobbly cube rotate scale switcher zoom fade screenshot water dbus
+LIBGL_ALWAYS_INDIRECT=1 compiz --replace --use-cow --indirect-rendering --strict-binding gconf move resize minimize place decoration wobbly fade cube rotate scale switcher zoom screenshot water dbus
diff --git a/x11-wm/compiz/files/compiz-nvidia b/x11-wm/compiz/files/compiz-nvidia
new file mode 100755
index 000000000000..4089ae3db913
--- /dev/null
+++ b/x11-wm/compiz/files/compiz-nvidia
@@ -0,0 +1,5 @@
+# Start window decorator
+gtk-window-decorator --replace &
+
+# Start compiz
+__GL_YIELD="NOTHING" compiz --replace --use-cow gconf move resize minimize place decoration wobbly fade cube rotate scale switcher zoom screenshot water dbus
diff --git a/x11-wm/compiz/files/compiz-xgl b/x11-wm/compiz/files/compiz-xgl
new file mode 100755
index 000000000000..114760d650f4
--- /dev/null
+++ b/x11-wm/compiz/files/compiz-xgl
@@ -0,0 +1,5 @@
+# Start window decorator
+gtk-window-decorator --replace &
+
+# Start compiz
+LD_LIBRARY_PATH="/usr/lib/opengl/xorg-x11" compiz --replace gconf move resize minimize place decoration wobbly fade cube rotate scale switcher zoom screenshot water dbus
diff --git a/x11-wm/compiz/files/digest-compiz-0.0.13_pre20060928 b/x11-wm/compiz/files/digest-compiz-0.0.13_pre20060928
new file mode 100644
index 000000000000..614d8a7c7f14
--- /dev/null
+++ b/x11-wm/compiz/files/digest-compiz-0.0.13_pre20060928
@@ -0,0 +1,3 @@
+MD5 2e9ffbcd82627b920c3c76f5808f5d7d compiz-20060928.tar.bz2 347383
+RMD160 76486a79bd295f173daa057b231fd3adf850b7e7 compiz-20060928.tar.bz2 347383
+SHA256 e40e82622eae6111c734d49668d74ef79156703cf56bb6836a06b2442d83db37 compiz-20060928.tar.bz2 347383