summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2003-03-19 16:01:22 +0000
committerMartin Schlemmer <azarah@gentoo.org>2003-03-19 16:01:22 +0000
commit43cd59448e4b5293561a724bf4ef65286562d048 (patch)
tree66591ebc5ea66b352b4d3bed71904f31ce34a40d /x11-wm
parent~x86 -> x86 and a few minor tweaks. (diff)
downloadgentoo-2-43cd59448e4b5293561a724bf4ef65286562d048.tar.gz
gentoo-2-43cd59448e4b5293561a724bf4ef65286562d048.tar.bz2
gentoo-2-43cd59448e4b5293561a724bf4ef65286562d048.zip
new version
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/xpde/ChangeLog7
-rw-r--r--x11-wm/xpde/files/digest-xpde-0.3.01
-rw-r--r--x11-wm/xpde/files/install-config.sh12
-rw-r--r--x11-wm/xpde/xpde-0.3.0.ebuild67
4 files changed, 86 insertions, 1 deletions
diff --git a/x11-wm/xpde/ChangeLog b/x11-wm/xpde/ChangeLog
index 6dbdcdd52cb8..5395e4e1c12d 100644
--- a/x11-wm/xpde/ChangeLog
+++ b/x11-wm/xpde/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/xpde
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/xpde/ChangeLog,v 1.3 2003/02/17 09:20:10 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/xpde/ChangeLog,v 1.4 2003/03/19 16:01:22 azarah Exp $
+
+*xpde-0.3.0 (19 Mar 2003)
+
+ 19 Mar 2003; Martin Schlemmer <azarah@gentoo.org> xpde-0.2.0.ebuild :
+ New version.
*xpde-0.2.0 (17 Feb 2003)
diff --git a/x11-wm/xpde/files/digest-xpde-0.3.0 b/x11-wm/xpde/files/digest-xpde-0.3.0
new file mode 100644
index 000000000000..c69a18cd6094
--- /dev/null
+++ b/x11-wm/xpde/files/digest-xpde-0.3.0
@@ -0,0 +1 @@
+MD5 09cfdbc2112faa2418696471b08e6ce8 xpde-0.3.0-20030315.tar.gz 9478094
diff --git a/x11-wm/xpde/files/install-config.sh b/x11-wm/xpde/files/install-config.sh
new file mode 100644
index 000000000000..5b0e9f468947
--- /dev/null
+++ b/x11-wm/xpde/files/install-config.sh
@@ -0,0 +1,12 @@
+#!/bin/bash
+
+if [ ! -d ${HOME}/.xpde ]
+then
+ cp -r /opt/xpde/share/defaultdesktop ~/.xpde
+ cp /opt/xpde/share/xinitrcDEFAULT ~/startXPDE
+ chmod +x ~/startXPDE
+
+fi
+
+echo "To use XPDE, add '~/startXPDE' to you .xinitrc"
+
diff --git a/x11-wm/xpde/xpde-0.3.0.ebuild b/x11-wm/xpde/xpde-0.3.0.ebuild
new file mode 100644
index 000000000000..9641aac85a11
--- /dev/null
+++ b/x11-wm/xpde/xpde-0.3.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/xpde/xpde-0.3.0.ebuild,v 1.1 2003/03/19 16:01:22 azarah Exp $
+
+IUSE=""
+S="${WORKDIR}/${P}"
+DESCRIPTION="A Desktop Environment modelled after the O/S from Redmond, WA"
+HOMEPAGE="http://www.xpde.com/"
+SRC_URI="http://www.xpde.com/dist2/${P}-20030315.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 -ppc -sparc -alpha"
+
+DEPEND="virtual/x11"
+
+src_compile() {
+ einfo ""
+ einfo "This is a binary-only package (sadly)"
+ einfo "No files to compile."
+ einfo ""
+}
+
+src_install() {
+ # The install is the ${S}/install.sh, Gentoo-ified
+ # As releases change often, don't just version
+ # bump and expect things to work right. Check for changes.
+ cd ${S}
+
+ dodir /opt/xpde/bin/apps
+ dodir /opt/xpde/bin/applets
+
+ dodir /opt/xpde/share/apps
+ dodir /opt/xpde/share/applets
+ dodir /opt/xpde/share/doc
+ dodir /opt/xpde/share/fonts
+ dodir /opt/xpde/share/icons
+
+ exeinto /opt/xpde/bin
+ doexe *.so* XPde XPwm stub.sh
+ doexe ${FILESDIR}/install-config.sh
+
+ exeinto /opt/xpde/bin/applets
+ doexe DateTimeProps appexec networkstatus networkproperties \
+ xpsu mouse keyboard regional desk
+
+ exeinto /opt/xpde/bin/apps
+ doexe taskmanager notepad calculator fileexplorer
+
+ dodir /opt/xpde/themes
+ cp -a themes/default ${D}/opt/xpde/themes
+
+ cp -a defaultdesktop ${D}/opt/xpde/share
+ cp xinitrcDEFAULT ${D}/opt/xpde/share
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL gpl.txt
+ dohtml -A txt,xml -r doc/*
+}
+
+pkg_postinst() {
+ einfo ""
+ einfo "sh /opt/xpde/bin/install-config.sh"
+ einfo ""
+ einfo "This will install a default configuration into your"
+ einfo "home directory"
+ einfo ""
+}