summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-02-07 21:47:20 +0000
committerJeroen Roovers <jer@gentoo.org>2012-02-07 21:47:20 +0000
commit61e18c6ead2eca935bd099e8394cd3d5d329fe00 (patch)
treecd1182f77c5f966c07fbf694da8f618a9181fa09 /x11-wm
parentNew package, bug 58091. Thanks to Konstantin Münning for ebuild and patch. (diff)
downloadgentoo-2-61e18c6ead2eca935bd099e8394cd3d5d329fe00.tar.gz
gentoo-2-61e18c6ead2eca935bd099e8394cd3d5d329fe00.tar.bz2
gentoo-2-61e18c6ead2eca935bd099e8394cd3d5d329fe00.zip
Version bump.
(Portage version: 2.2.0_alpha85/cvs/Linux x86_64)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/matwm2/ChangeLog9
-rw-r--r--x11-wm/matwm2/matwm2-0.1.1.ebuild55
2 files changed, 62 insertions, 2 deletions
diff --git a/x11-wm/matwm2/ChangeLog b/x11-wm/matwm2/ChangeLog
index 44f9c9fab797..c4bdf862e896 100644
--- a/x11-wm/matwm2/ChangeLog
+++ b/x11-wm/matwm2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/matwm2
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/matwm2/ChangeLog,v 1.2 2011/11/03 20:31:36 xarthisius Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/matwm2/ChangeLog,v 1.3 2012/02/07 21:47:20 jer Exp $
+
+*matwm2-0.1.1 (07 Feb 2012)
+
+ 07 Feb 2012; Jeroen Roovers <jer@gentoo.org> +matwm2-0.1.1.ebuild:
+ Version bump.
03 Nov 2011; Kacper Kowalik <xarthisius@gentoo.org> matwm2-0.0.96.ebuild:
Fix HOMEPAGE and SRC_URI wrt bug 379631 by Jesus Guerrero
diff --git a/x11-wm/matwm2/matwm2-0.1.1.ebuild b/x11-wm/matwm2/matwm2-0.1.1.ebuild
new file mode 100644
index 000000000000..80f47bf460ea
--- /dev/null
+++ b/x11-wm/matwm2/matwm2-0.1.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/matwm2/matwm2-0.1.1.ebuild,v 1.1 2012/02/07 21:47:20 jer Exp $
+
+EAPI=4
+inherit toolchain-funcs
+
+DESCRIPTION="Simple EWMH compatible window manager with titlebars and frames"
+HOMEPAGE="http://squidjam.com/matwm/"
+SRC_URI="http://squidjam.com/matwm/pub/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug xft xinerama"
+
+RDEPEND="
+ x11-libs/libXext
+ x11-libs/libX11
+ debug? ( x11-proto/xproto )
+ xft? ( x11-libs/libXft )
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="
+ ${RDEPEND}
+ x11-proto/xextproto
+ xinerama? ( x11-proto/xineramaproto )
+"
+
+src_configure() {
+ # configure is not autotools based
+ # --disable-shape left out because the code is broken
+ ./configure \
+ $( use debug && echo --enable-debug ) \
+ $( use xft || echo --disable-xft ) \
+ $( use xinerama || echo --disable-xinerama ) \
+ || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ dodoc BUGS ChangeLog default_matwmrc README TODO
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}"/${PN}.desktop
+
+ echo ${PN} > "${T}"/${PN}
+ exeinto /etc/X11/Sessions
+ doexe "${T}"/${PN}
+}