summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-03-06 18:31:27 +0000
committerJeroen Roovers <jer@gentoo.org>2014-03-06 18:31:27 +0000
commit683f8f6de8706dac77805091e60a16d44cef9e3c (patch)
tree7e25b084d7da82e1b8febb84a0d958224b196a29 /x11-wm
parentRemove unneeded HPPA settings. (diff)
downloadgentoo-2-683f8f6de8706dac77805091e60a16d44cef9e3c.tar.gz
gentoo-2-683f8f6de8706dac77805091e60a16d44cef9e3c.tar.bz2
gentoo-2-683f8f6de8706dac77805091e60a16d44cef9e3c.zip
Add USE=sloppy.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/ratpoison/ChangeLog8
-rw-r--r--x11-wm/ratpoison/metadata.xml1
-rw-r--r--x11-wm/ratpoison/ratpoison-1.4.6-r1.ebuild92
-rw-r--r--x11-wm/ratpoison/ratpoison-9999.ebuild21
4 files changed, 117 insertions, 5 deletions
diff --git a/x11-wm/ratpoison/ChangeLog b/x11-wm/ratpoison/ChangeLog
index 8c41bcb42ddc..a43f868d7f6d 100644
--- a/x11-wm/ratpoison/ChangeLog
+++ b/x11-wm/ratpoison/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-wm/ratpoison
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/ratpoison/ChangeLog,v 1.95 2014/01/29 12:21:49 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/ratpoison/ChangeLog,v 1.96 2014/03/06 18:31:27 jer Exp $
+
+*ratpoison-1.4.6-r1 (06 Mar 2014)
+
+ 06 Mar 2014; Jeroen Roovers <jer@gentoo.org> +ratpoison-1.4.6-r1.ebuild,
+ ratpoison-9999.ebuild, metadata.xml:
+ Add USE=sloppy.
*ratpoison-9999 (29 Jan 2014)
diff --git a/x11-wm/ratpoison/metadata.xml b/x11-wm/ratpoison/metadata.xml
index 16c27aec7296..35f6ddeb9f7f 100644
--- a/x11-wm/ratpoison/metadata.xml
+++ b/x11-wm/ratpoison/metadata.xml
@@ -17,5 +17,6 @@
</longdescription>
<use>
<flag name="history">Use <pkg>sys-libs/readline</pkg> for history handling</flag>
+ <flag name="sloppy">Install sloppy, a focus-follows-mouse implementation for ratpoison</flag>
</use>
</pkgmetadata>
diff --git a/x11-wm/ratpoison/ratpoison-1.4.6-r1.ebuild b/x11-wm/ratpoison/ratpoison-1.4.6-r1.ebuild
new file mode 100644
index 000000000000..590e2fb7d9fc
--- /dev/null
+++ b/x11-wm/ratpoison/ratpoison-1.4.6-r1.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/ratpoison/ratpoison-1.4.6-r1.ebuild,v 1.1 2014/03/06 18:31:27 jer Exp $
+
+EAPI=5
+
+inherit elisp-common eutils toolchain-funcs
+
+DESCRIPTION="Ratpoison is an extremely light-weight and barebones wm modelled after screen"
+HOMEPAGE="http://www.nongnu.org/ratpoison/"
+SRC_URI="http://savannah.nongnu.org/download/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+IUSE="debug emacs +history +xft sloppy"
+
+RDEPEND="
+ emacs? ( virtual/emacs )
+ history? ( sys-libs/readline )
+ virtual/perl-PodParser
+ x11-libs/libXinerama
+ x11-libs/libXtst
+ xft? ( x11-libs/libXft )
+"
+DEPEND="
+ ${RDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig
+"
+
+SITEFILE=50ratpoison-gentoo.el
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+src_prepare() {
+ epatch "${FILESDIR}/ratpoison.el-gentoo.patch"
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_with xft) \
+ $(usex history '' --disable-history)
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}"
+ if use emacs; then
+ elisp-compile contrib/ratpoison.el || die "elisp-compile failed"
+ fi
+
+ if use sloppy; then
+ pushd contrib
+ $(tc-getCC) \
+ ${CFLAGS} \
+ ${LDFLAGS} \
+ -o sloppy{,.c} \
+ $( $(tc-getPKG_CONFIG) --libs x11) \
+ || die
+ fi
+}
+
+src_install() {
+ default
+
+ exeinto /etc/X11/Sessions
+ newexe "${FILESDIR}"/ratpoison.xsession ratpoison
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}"/${PN}.desktop
+
+ use sloppy && dobin contrib/sloppy
+
+ docinto example
+ dodoc contrib/{genrpbindings,split.sh} \
+ doc/{ipaq.ratpoisonrc,sample.ratpoisonrc}
+
+ rm -rf "${ED}/usr/share/"{doc/ratpoison,ratpoison}
+
+ if use emacs; then
+ elisp-install ${PN} contrib/ratpoison.*
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/x11-wm/ratpoison/ratpoison-9999.ebuild b/x11-wm/ratpoison/ratpoison-9999.ebuild
index 8583ff8c3558..c3d3beb36ed2 100644
--- a/x11-wm/ratpoison/ratpoison-9999.ebuild
+++ b/x11-wm/ratpoison/ratpoison-9999.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/ratpoison/ratpoison-9999.ebuild,v 1.1 2014/01/29 12:21:49 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/ratpoison/ratpoison-9999.ebuild,v 1.2 2014/03/06 18:31:27 jer Exp $
EAPI=5
-inherit autotools elisp-common eutils git-r3
+inherit autotools elisp-common eutils git-r3 toolchain-funcs
DESCRIPTION="Ratpoison is an extremely light-weight and barebones wm modelled after screen"
HOMEPAGE="http://www.nongnu.org/ratpoison/"
@@ -13,7 +13,7 @@ EGIT_REPO_URI="git://git.savannah.nongnu.org/ratpoison.git"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="debug emacs +history +xft"
+IUSE="debug emacs +history sloppy +xft"
RDEPEND="
emacs? ( virtual/emacs )
@@ -26,6 +26,7 @@ RDEPEND="
DEPEND="
${RDEPEND}
app-arch/xz-utils
+ virtual/pkgconfig
"
SITEFILE=50ratpoison-gentoo.el
@@ -49,6 +50,16 @@ src_compile() {
if use emacs; then
elisp-compile contrib/ratpoison.el || die "elisp-compile failed"
fi
+
+ if use sloppy; then
+ pushd contrib
+ $(tc-getCC) \
+ ${CFLAGS} \
+ ${LDFLAGS} \
+ -o sloppy{,.c} \
+ $( $(tc-getPKG_CONFIG) --libs x11) \
+ || die
+ fi
}
src_install() {
@@ -58,7 +69,9 @@ src_install() {
newexe "${FILESDIR}"/ratpoison.xsession ratpoison
insinto /usr/share/xsessions
- doins "${FILESDIR}"/${PN}.desktop || die
+ doins "${FILESDIR}"/${PN}.desktop
+
+ use sloppy && dobin contrib/sloppy
docinto example
dodoc contrib/{genrpbindings,split.sh} \