summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-05-22 22:45:18 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-05-22 22:45:18 +0000
commit6ab573cf981f6b196b84979762b5dfb6bd080591 (patch)
tree0979393409a8af9c422ed6761aab7a96ccc757b9 /x11-wm
parentmore gnome2 stuff (diff)
downloadgentoo-2-6ab573cf981f6b196b84979762b5dfb6bd080591.tar.gz
gentoo-2-6ab573cf981f6b196b84979762b5dfb6bd080591.tar.bz2
gentoo-2-6ab573cf981f6b196b84979762b5dfb6bd080591.zip
snapshot addons
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/sawfish/ChangeLog5
-rw-r--r--x11-wm/sawfish/files/digest-sawfish-200204191
-rw-r--r--x11-wm/sawfish/files/digest-sawfish-20020502-r11
-rw-r--r--x11-wm/sawfish/sawfish-20020419.ebuild67
-rw-r--r--x11-wm/sawfish/sawfish-20020502-r1.ebuild61
5 files changed, 134 insertions, 1 deletions
diff --git a/x11-wm/sawfish/ChangeLog b/x11-wm/sawfish/ChangeLog
index dad326bdf1c4..80f545e23cdd 100644
--- a/x11-wm/sawfish/ChangeLog
+++ b/x11-wm/sawfish/ChangeLog
@@ -1,7 +1,10 @@
# ChangeLog for x11-wm/sawfish
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/ChangeLog,v 1.6 2002/05/22 18:28:42 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/ChangeLog,v 1.7 2002/05/22 22:45:18 spider Exp $
+*sawfish-20020419 (22 May 2002)
+ 22 May 2002; Spider <spider@gentoo.org> sawfish-20020419.ebuild :
+ gnome2 snapshots
*sawfish-1.0.1-r4 (21 May 2002)
21 May 2002; Spider <spider@gentoo.org> sawfish-1.0.1-r4.ebuild ChangeLog :
diff --git a/x11-wm/sawfish/files/digest-sawfish-20020419 b/x11-wm/sawfish/files/digest-sawfish-20020419
new file mode 100644
index 000000000000..3f94f28281e8
--- /dev/null
+++ b/x11-wm/sawfish/files/digest-sawfish-20020419
@@ -0,0 +1 @@
+MD5 076e5168f999bf2df42d448374e63775 sawfish-2002-04-19.tar.bz2 1096896
diff --git a/x11-wm/sawfish/files/digest-sawfish-20020502-r1 b/x11-wm/sawfish/files/digest-sawfish-20020502-r1
new file mode 100644
index 000000000000..2b8202504bdf
--- /dev/null
+++ b/x11-wm/sawfish/files/digest-sawfish-20020502-r1
@@ -0,0 +1 @@
+MD5 bb3b6a5dc19257bcbbdf3d8cd97eb8fd sawfish-2002-05-02.tar.bz2 1100668
diff --git a/x11-wm/sawfish/sawfish-20020419.ebuild b/x11-wm/sawfish/sawfish-20020419.ebuild
new file mode 100644
index 000000000000..cadd9bd118ae
--- /dev/null
+++ b/x11-wm/sawfish/sawfish-20020419.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/sawfish-20020419.ebuild,v 1.1 2002/05/22 22:45:18 spider Exp $
+
+# Do _NOT_ strip symbols in the build! Need both lines for Portage 1.8.9+
+DEBUG="yes"
+RESTRICT="nostrip"
+# force debug information
+CFLAGS="${CFLAGS} -g"
+CXXFLAGS="${CXXFLAGS} -g"
+
+
+S=${WORKDIR}/sawfish-2002-04-19
+DESCRIPTION="Extensible window manager using a Lisp-based scripting language"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/pre-gnome2/sources/sawfish/sawfish-2002-04-19.tar.bz2"
+HOMEPAGE="http://sawmill.sourceforge.net/"
+
+DEPEND=">=dev-util/pkgconfig-0.12.0
+ >=x11-libs/rep-gtk-20020419
+ >=dev-libs/librep-20020419
+ >=media-libs/imlib-1.9.10-r1
+ esd? ( >=media-sound/esound-0.2.22 )
+ readline? ( >=sys-libs/readline-4.1 )
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf
+ ## Gdk-pixbuf in gnome2. I can't find it.
+ myconf=" --without-gdk-pixbuf "
+ myconf="${myconf} --with-gnome-prefix=/usr --disable-gnome-widgets --enable-capplet --enable-themer"
+
+ if [ "`use esd`" ] ; then
+ myconf="${myconf} --with-esd"
+ else
+ myconf="${myconf} --without-esd"
+ fi
+
+ if [ "`use readline`" ] ; then
+ myconf="${myconf} --with-readline"
+ else
+ myconf="${myconf} --without-readline"
+ fi
+
+ if [ -z "`use nls`" ] ; then
+ myconf="${myconf} --disable-linguas"
+ fi
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --libexecdir=/usr/lib \
+ --with-audiofile ${myconf} || die
+
+ #pmake doesn't work, stick with make
+ # old comment. try again.
+ make || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS BUGS COPYING ChangeLog DOC FAQ NEWS README THANKS TODO
+
+ # Add to Gnome CC's Window Manager list
+ insinto /usr/share/gnome/wm-properties
+ doins ${FILESDIR}/Sawfish.desktop
+
+}
diff --git a/x11-wm/sawfish/sawfish-20020502-r1.ebuild b/x11-wm/sawfish/sawfish-20020502-r1.ebuild
new file mode 100644
index 000000000000..9de784b84b2c
--- /dev/null
+++ b/x11-wm/sawfish/sawfish-20020502-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Spider <spider@gentoo.org>
+# Maintainer: Spider <spider@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/sawfish-20020502-r1.ebuild,v 1.1 2002/05/22 22:45:18 spider Exp $
+
+# Do _NOT_ strip symbols in the build! Need both lines for Portage 1.8.9+
+DEBUG="yes"
+RESTRICT="nostrip"
+# force debug information
+CFLAGS="${CFLAGS} -g"
+CXXFLAGS="${CXXFLAGS} -g"
+
+MY_P=${PN}-2002-05-02
+
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Extensible window manager using a Lisp-based scripting language"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/pre-gnome2/sources/${PN}/${MY_P}.tar.bz2"
+HOMEPAGE="http://sawmill.sourceforge.net/"
+
+DEPEND=">=dev-util/pkgconfig-0.12.0
+ >=x11-libs/rep-gtk-20020419
+ >=dev-libs/librep-20020419
+ >=media-libs/imlib-1.9.10-r1
+ esd? ( >=media-sound/esound-0.2.22 )
+ readline? ( >=sys-libs/readline-4.1 )
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ # hack around source bug
+ echo "(eval-when-compile (require 'sawfish.wm.commands.xterm))" >>lisp/sawfish/wm/defaults.jl
+ local myconf
+ myconf="${myconf} --with-gnome-prefix=/usr"
+ myconf="${myconf} --enable-gnome-widgets "
+ myconf="${myconf} --enable-capplet"
+ myconf="${myconf} --enable-themer"
+
+ use esd && myconf="${myconf} --with-esd" ||myconf="${myconf} --without-esd"
+ use readline && myconf="${myconf} --with-readline" || myconf="${myconf} --without-readline"
+ use nls || myconf="${myconf} --disable-linguas"
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --libexecdir=/usr/lib \
+ --with-audiofile ${myconf} || die
+ mkdir ${S}/src/.libs
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS BUGS COPYING ChangeLog DOC FAQ NEWS README THANKS TODO
+
+ # Add to Gnome CC's Window Manager list
+ insinto /usr/share/gnome/wm-properties
+ doins ${FILESDIR}/Sawfish.desktop
+
+}
+
+
+