summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2012-07-11 13:10:11 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2012-07-11 13:10:11 +0000
commita2acdc36f194780fba14b9efc5853ae1fcd39e4a (patch)
treecb868857a14c755341c470241ae2ea19dc0d63db /x11-wm
parentnet-nds/adtool: Version Bump, buffer overflow fix (diff)
downloadgentoo-2-a2acdc36f194780fba14b9efc5853ae1fcd39e4a.tar.gz
gentoo-2-a2acdc36f194780fba14b9efc5853ae1fcd39e4a.tar.bz2
gentoo-2-a2acdc36f194780fba14b9efc5853ae1fcd39e4a.zip
Fix underlinking on libWMaker, bug #425788
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/windowmaker/ChangeLog9
-rw-r--r--x11-wm/windowmaker/files/windowmaker-0.95.3-fix_underlinking.patch15
-rw-r--r--x11-wm/windowmaker/windowmaker-0.95.3-r1.ebuild106
3 files changed, 129 insertions, 1 deletions
diff --git a/x11-wm/windowmaker/ChangeLog b/x11-wm/windowmaker/ChangeLog
index 61a47a5d9dc4..3314a7fb8bf4 100644
--- a/x11-wm/windowmaker/ChangeLog
+++ b/x11-wm/windowmaker/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-wm/windowmaker
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/windowmaker/ChangeLog,v 1.134 2012/06/07 22:42:15 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/windowmaker/ChangeLog,v 1.135 2012/07/11 13:10:11 voyageur Exp $
+
+*windowmaker-0.95.3-r1 (11 Jul 2012)
+
+ 11 Jul 2012; Bernard Cafarelli <voyageur@gentoo.org>
+ +windowmaker-0.95.3-r1.ebuild,
+ +files/windowmaker-0.95.3-fix_underlinking.patch:
+ Fix underlinking on libWMaker, bug #425788
*windowmaker-0.95.3 (07 Jun 2012)
diff --git a/x11-wm/windowmaker/files/windowmaker-0.95.3-fix_underlinking.patch b/x11-wm/windowmaker/files/windowmaker-0.95.3-fix_underlinking.patch
new file mode 100644
index 000000000000..cd88709dc148
--- /dev/null
+++ b/x11-wm/windowmaker/files/windowmaker-0.95.3-fix_underlinking.patch
@@ -0,0 +1,15 @@
+diff --git a/wmlib/Makefile.am b/wmlib/Makefile.am
+index 0f8201f..7b95d1f 100644
+--- a/wmlib/Makefile.am
++++ b/wmlib/Makefile.am
+@@ -2,6 +2,7 @@
+ AUTOMAKE_OPTIONS = no-dependencies
+
+ libWMaker_la_LDFLAGS = -version-info 1:1:0
++libWMaker_la_LIBADD = @LIBRARY_SEARCH_PATH@ @XLIBS@
+ lib_LTLIBRARIES = libWMaker.la
+
+ include_HEADERS = WMaker.h
+--
+1.7.8.6
+
diff --git a/x11-wm/windowmaker/windowmaker-0.95.3-r1.ebuild b/x11-wm/windowmaker/windowmaker-0.95.3-r1.ebuild
new file mode 100644
index 000000000000..0dcaae83b4ec
--- /dev/null
+++ b/x11-wm/windowmaker/windowmaker-0.95.3-r1.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/windowmaker/windowmaker-0.95.3-r1.ebuild,v 1.1 2012/07/11 13:10:11 voyageur Exp $
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="The fast and light GNUstep window manager"
+HOMEPAGE="http://www.windowmaker.org/"
+SRC_URI=" http://windowmaker.org/pub/source/release/${P/windowm/WindowM}.tar.gz
+ http://www.windowmaker.org/pub/source/release/WindowMaker-extra-0.1.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="gif jpeg nls png tiff modelock xinerama xrandr"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+
+DEPEND="media-libs/fontconfig
+ >=x11-libs/libXft-2.1.0
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libXv
+ gif? ( >=media-libs/giflib-4.1.0-r3 )
+ png? ( media-libs/libpng:0 )
+ jpeg? ( virtual/jpeg )
+ tiff? ( media-libs/tiff:0 )
+ xinerama? ( x11-libs/libXinerama )
+ xrandr? ( x11-libs/libXrandr )"
+RDEPEND="${DEPEND}
+ nls? ( >=sys-devel/gettext-0.10.39 )"
+
+S=${WORKDIR}/${P/windowm/WindowM}
+
+src_prepare() {
+ # Fix some paths
+ for file in WindowMaker/*menu* util/wmgenmenu.c; do
+ if [[ -r $file ]] ; then
+ sed -i -e "s:/usr/local/GNUstep/Applications/WPrefs.app:${EPREFIX}/usr/bin/:g;" "$file" || die
+ sed -i -e "s:/usr/local/share/WindowMaker:${EPREFIX}/usr/share/WindowMaker:g;" "$file" || die
+ sed -i -e "s:/opt/share/WindowMaker:${EPREFIX}/usr/share/WindowMaker:g;" "$file" || die
+ fi;
+ done;
+
+ epatch "${FILESDIR}"/${P}-fix_underlinking.patch
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+
+ # image format types
+ # xpm is provided by X itself
+ myconf="--enable-xpm $(use_enable png) $(use_enable jpeg) $(use_enable gif) $(use_enable tiff)"
+
+ # non required X capabilities
+ myconf="${myconf} $(use_enable modelock) $(use_enable xrandr) $(use_enable xinerama)"
+
+ if use nls; then
+ [[ -z $LINGUAS ]] && export LINGUAS="`ls po/*.po | sed 's:po/\(.*\)\.po$:\1:'`"
+ else
+ myconf="${myconf} --disable-locale"
+ fi
+
+ # default settings with $myconf appended
+ econf \
+ --sysconfdir="${EPREFIX}"/etc/X11 \
+ --with-x \
+ --enable-usermenu \
+ --with-pixmapdir="${EPREFIX}"/usr/share/pixmaps \
+ --with-nlsdir="${EPREFIX}"/usr/share/locale \
+ ${myconf}
+
+ cd ../WindowMaker-extra-0.1
+ econf
+}
+
+src_compile() {
+ emake
+
+ # WindowMaker Extra Package (themes and icons)
+ cd ../WindowMaker-extra-0.1
+ emake
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc AUTHORS BUGFORM BUGS ChangeLog INSTALL* FAQ* \
+ README* NEWS TODO
+
+ # WindowMaker Extra
+ cd ../WindowMaker-extra-0.1
+ emake DESTDIR="${D}" install
+
+ newdoc README README.extra
+
+ # create wmaker session shell script
+ echo "#!/usr/bin/env bash" > wmaker
+ echo "${EPREFIX}/usr/bin/wmaker" >> wmaker
+ exeinto /etc/X11/Sessions/
+ doexe wmaker
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}"/wmaker.desktop
+ make_desktop_entry /usr/bin/wmaker
+}