summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-07-04 08:46:54 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-07-04 08:46:54 +0000
commita5f80966f871b92493792caf5deb1eb73dea13c4 (patch)
tree528e36a7b9d14926375fa94ef143731b96f4021c /x11-wm
parentVersion bump. (diff)
downloadgentoo-2-a5f80966f871b92493792caf5deb1eb73dea13c4.tar.gz
gentoo-2-a5f80966f871b92493792caf5deb1eb73dea13c4.tar.bz2
gentoo-2-a5f80966f871b92493792caf5deb1eb73dea13c4.zip
Properly detect libpng if USE="-truetype" wrt bug 326803. Thanks to Carlo Marcelo Arenas Belon <carenas@sajinet.com.pe> for report and patch.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/pekwm/ChangeLog7
-rw-r--r--x11-wm/pekwm/files/pekwm-0.1.12-configure.patch15
-rw-r--r--x11-wm/pekwm/pekwm-0.1.12.ebuild17
3 files changed, 33 insertions, 6 deletions
diff --git a/x11-wm/pekwm/ChangeLog b/x11-wm/pekwm/ChangeLog
index 9c9140632032..15e4ba0e19c1 100644
--- a/x11-wm/pekwm/ChangeLog
+++ b/x11-wm/pekwm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/pekwm
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/pekwm/ChangeLog,v 1.54 2010/06/02 07:57:08 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/pekwm/ChangeLog,v 1.55 2010/07/04 08:46:54 xarthisius Exp $
+
+ 04 Jul 2010; Kacper Kowalik <xarthisius@gentoo.org> pekwm-0.1.12.ebuild,
+ +files/pekwm-0.1.12-configure.patch:
+ Properly detect libpng if USE="-truetype" wrt bug 326803. Thanks to Carlo
+ Marcelo Arenas Belon <carenas@sajinet.com.pe> for report and patch.
*pekwm-0.1.12 (02 Jun 2010)
diff --git a/x11-wm/pekwm/files/pekwm-0.1.12-configure.patch b/x11-wm/pekwm/files/pekwm-0.1.12-configure.patch
new file mode 100644
index 000000000000..a1ce351917d4
--- /dev/null
+++ b/x11-wm/pekwm/files/pekwm-0.1.12-configure.patch
@@ -0,0 +1,15 @@
+Allows to properly detect libpng if USE="-truetype"
+
+https://bugs.gentoo.org/show_bug.cgi?id=326803
+
+Patch written by Carlo Marcelo Arenas Belon <carenas@sajinet.com.pe>
+--- configure.ac
++++ configure.ac
+@@ -10,6 +10,7 @@
+ AC_PROG_CXX
+ AC_PROG_INSTALL
+ AC_PROG_SED
++PKG_PROG_PKG_CONFIG
+
+ AC_LANG_CPLUSPLUS
+
diff --git a/x11-wm/pekwm/pekwm-0.1.12.ebuild b/x11-wm/pekwm/pekwm-0.1.12.ebuild
index d11aba394607..83803ab79ccd 100644
--- a/x11-wm/pekwm/pekwm-0.1.12.ebuild
+++ b/x11-wm/pekwm/pekwm-0.1.12.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/pekwm/pekwm-0.1.12.ebuild,v 1.1 2010/06/02 07:57:08 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/pekwm/pekwm-0.1.12.ebuild,v 1.2 2010/07/04 08:46:54 xarthisius Exp $
EAPI=2
-inherit eutils
+inherit autotools eutils
DESCRIPTION="A small window mananger based on aewm++"
HOMEPAGE="http://pekwm.org/"
@@ -15,16 +15,23 @@ SLOT="0"
KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86 ~x86-fbsd"
IUSE="debug truetype xinerama"
-DEPEND="media-libs/jpeg:0
+CDEPEND="media-libs/jpeg:0
media-libs/libpng
x11-libs/libXpm
x11-libs/libXrandr
x11-libs/libXrender
truetype? ( x11-libs/libXft )
xinerama? ( x11-libs/libXinerama )"
-RDEPEND="${DEPEND}
+DEPEND="${CDEPEND}
+ dev-util/pkgconfig"
+RDEPEND="${CDEPEND}
x11-apps/xprop"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-configure.patch
+ eautoreconf
+}
+
src_configure() {
econf \
$(use_enable debug) \
@@ -41,7 +48,7 @@ src_configure() {
src_install() {
emake DESTDIR="${D}" install || die
- dodoc AUTHORS ChangeLog NEWS README
+ dodoc AUTHORS ChangeLog NEWS README || die
rm "${WORKDIR}/themes/Ace/.theme.swp"
mv "${WORKDIR}/themes/"* "${D}/usr/share/${PN}/themes/"