summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-07-27 13:11:22 +0000
committerPacho Ramos <pacho@gentoo.org>2013-07-27 13:11:22 +0000
commitbd17ff9aa40574974bb3455a46280915513ac261 (patch)
tree8bde6b982f5dad6963e6c2a880b447cd679b57ac /x11-wm
parentVersion bump to 4.5.13 and 5.0.9 to fix sec issues. Closes bug#477900. Remove... (diff)
downloadgentoo-2-bd17ff9aa40574974bb3455a46280915513ac261.tar.gz
gentoo-2-bd17ff9aa40574974bb3455a46280915513ac261.tar.bz2
gentoo-2-bd17ff9aa40574974bb3455a46280915513ac261.zip
Fix maximized windows jumping to a different monitor (#470248#c37 by kisak42)
(Portage version: 2.1.13.1/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/muffin/ChangeLog9
-rw-r--r--x11-wm/muffin/files/muffin-1.8.2-maximized-jump.patch29
-rw-r--r--x11-wm/muffin/muffin-1.8.2-r1.ebuild (renamed from x11-wm/muffin/muffin-1.8.2.ebuild)8
3 files changed, 42 insertions, 4 deletions
diff --git a/x11-wm/muffin/ChangeLog b/x11-wm/muffin/ChangeLog
index 154dacf8244d..aa1cefe264b9 100644
--- a/x11-wm/muffin/ChangeLog
+++ b/x11-wm/muffin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-wm/muffin
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/muffin/ChangeLog,v 1.12 2013/07/27 09:52:56 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/muffin/ChangeLog,v 1.13 2013/07/27 13:11:21 pacho Exp $
+
+*muffin-1.8.2-r1 (27 Jul 2013)
+
+ 27 Jul 2013; Pacho Ramos <pacho@gentoo.org>
+ +files/muffin-1.8.2-maximized-jump.patch, +muffin-1.8.2-r1.ebuild,
+ -muffin-1.8.2.ebuild:
+ Fix maximized windows jumping to a different monitor (#470248#c37 by kisak42)
*muffin-1.8.2 (27 Jul 2013)
diff --git a/x11-wm/muffin/files/muffin-1.8.2-maximized-jump.patch b/x11-wm/muffin/files/muffin-1.8.2-maximized-jump.patch
new file mode 100644
index 000000000000..f7874c0b6a96
--- /dev/null
+++ b/x11-wm/muffin/files/muffin-1.8.2-maximized-jump.patch
@@ -0,0 +1,29 @@
+From 00fdf6c3078b3cf34707f7d740bf797d1ca77414 Mon Sep 17 00:00:00 2001
+From: Albert Pool <albertpool@solcon.nl>
+Date: Tue, 9 Jul 2013 16:08:59 +0200
+Subject: [PATCH] Fix maximized windows jumping to a different monitor
+
+Commit e5b46747d67f6f75ef06272d91f7f8cfc36af058 upstream
+---
+ src/core/constraints.c | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/src/core/constraints.c b/src/core/constraints.c
+index 4c4dedd..630c41c 100644
+--- a/src/core/constraints.c
++++ b/src/core/constraints.c
+@@ -567,6 +567,11 @@ typedef gboolean (* ConstraintFunc) (MetaWindow *window,
+ .083 * info->work_area_monitor.height;
+ }
+
++ /* idle_move_resize() uses the user_rect,
++ * so make sure it uses the placed coordinates.
++ */
++ window->user_rect = info->current;
++
+ if (window->maximize_horizontally_after_placement ||
+ window->maximize_vertically_after_placement)
+ meta_window_maximize_internal (window,
+--
+1.8.1.6
+
diff --git a/x11-wm/muffin/muffin-1.8.2.ebuild b/x11-wm/muffin/muffin-1.8.2-r1.ebuild
index eea33ec9cde9..3f89d554ccbc 100644
--- a/x11-wm/muffin/muffin-1.8.2.ebuild
+++ b/x11-wm/muffin/muffin-1.8.2-r1.ebuild
@@ -1,12 +1,11 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/muffin/muffin-1.8.2.ebuild,v 1.1 2013/07/27 09:52:56 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/muffin/muffin-1.8.2-r1.ebuild,v 1.1 2013/07/27 13:11:21 pacho Exp $
EAPI="5"
GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes"
-inherit autotools gnome2
+inherit autotools eutils gnome2
DESCRIPTION="Compositing window manager forked from Mutter for use with Cinnamon"
HOMEPAGE="http://cinnamon.linuxmint.com/"
@@ -62,6 +61,9 @@ RDEPEND="${COMMON_DEPEND}
"
src_prepare() {
+ # Fix maximized windows jumping to a different monitor
+ epatch "${FILESDIR}/${PN}-1.8.2-maximized-jump.patch"
+
# Regenerate obsolete Makefile.in
eautoreconf
gnome2_src_prepare