summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2012-08-01 10:48:37 +0000
committerMichael Weber <xmw@gentoo.org>2012-08-01 10:48:37 +0000
commitc9a39520d17bba61d0a77204b99defea861719d1 (patch)
treeb0c198f2b7246607fc95627859e41d67e6af0499 /x11-wm
parentMarked stable on AMD64 based on arch testing by Maurizio "k01" Camisaschi & E... (diff)
downloadgentoo-2-c9a39520d17bba61d0a77204b99defea861719d1.tar.gz
gentoo-2-c9a39520d17bba61d0a77204b99defea861719d1.tar.bz2
gentoo-2-c9a39520d17bba61d0a77204b99defea861719d1.zip
Version bump (thanks noptrix for the hint)
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/spectrwm/ChangeLog8
-rw-r--r--x11-wm/spectrwm/files/spectrwm-1.2.0-makefile.patch32
-rw-r--r--x11-wm/spectrwm/spectrwm-1.2.0.ebuild43
3 files changed, 82 insertions, 1 deletions
diff --git a/x11-wm/spectrwm/ChangeLog b/x11-wm/spectrwm/ChangeLog
index 3dba72596e7f..10f16e7c2f28 100644
--- a/x11-wm/spectrwm/ChangeLog
+++ b/x11-wm/spectrwm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-wm/spectrwm
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/spectrwm/ChangeLog,v 1.3 2012/07/09 16:28:17 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/spectrwm/ChangeLog,v 1.4 2012/08/01 10:48:36 xmw Exp $
+
+*spectrwm-1.2.0 (01 Aug 2012)
+
+ 01 Aug 2012; Michael Weber <xmw@gentoo.org>
+ +files/spectrwm-1.2.0-makefile.patch, +spectrwm-1.2.0.ebuild:
+ Version bump (thanks noptrix for the hint)
*spectrwm-1.1.1 (09 Jul 2012)
diff --git a/x11-wm/spectrwm/files/spectrwm-1.2.0-makefile.patch b/x11-wm/spectrwm/files/spectrwm-1.2.0-makefile.patch
new file mode 100644
index 000000000000..f389456c0ef4
--- /dev/null
+++ b/x11-wm/spectrwm/files/spectrwm-1.2.0-makefile.patch
@@ -0,0 +1,32 @@
+--- spectrwm-1.2.0/linux/Makefile
++++ spectrwm-1.2.0/linux/Makefile
+@@ -1,5 +1,5 @@
+-CFLAGS+= -Wall -Wextra -Wshadow -g -D_GNU_SOURCE -I. -I/usr/include/freetype2
+-CFLAGS+= -DSWM_LIB=\"$(LIBDIR)/libswmhack.so.$(LVERS)\"
++CFLAGS+= -Wall -Wextra -Wshadow -D_GNU_SOURCE -I. -I/usr/include/freetype2
++CFLAGS+= -DSWM_LIB=\"libswmhack.so.$(LVERS)\"
+ LDADD+= -lX11 -lX11-xcb -lxcb -lxcb-icccm -lxcb-randr -lxcb-keysyms -lxcb-util -lxcb-xtest -lXft
+
+ PREFIX?= /usr/local
+@@ -7,7 +7,7 @@
+ LIBDIR?= $(PREFIX)/lib
+ MANDIR?= $(PREFIX)/share/man
+
+-CC= gcc
++CC ?= gcc
+
+ LVERS= $(shell . ../lib/shlib_version; echo $$major.$$minor)
+
+@@ -29,10 +29,10 @@
+ $(CC) $(LDFLAGS) -o $@ $+ $(LDADD)
+
+ %.so: %.c
+- $(CC) $(CFLAGS) -c -fpic -DPIC $+ -o $@
++ $(CC) $(CFLAGS) $(LDFLAGS) -c -fpic -DPIC $+ -o $@
+
+ libswmhack.so.$(LVERS): swm_hack.so
+- $(CC) -shared -fpic -o libswmhack.so.$(LVERS) swm_hack.so $(LDADD)
++ $(CC) $(LDFLAGS) -Wl,-soname,$@ -shared -fpic -o libswmhack.so.$(LVERS) swm_hack.so $(LDADD)
+
+ install: all
+ install -m 755 -d $(DESTDIR)$(BINDIR)
diff --git a/x11-wm/spectrwm/spectrwm-1.2.0.ebuild b/x11-wm/spectrwm/spectrwm-1.2.0.ebuild
new file mode 100644
index 000000000000..80459e9c8101
--- /dev/null
+++ b/x11-wm/spectrwm/spectrwm-1.2.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/spectrwm/spectrwm-1.2.0.ebuild,v 1.1 2012/08/01 10:48:36 xmw Exp $
+
+EAPI=4
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Small dynamic tiling window manager for X11"
+HOMEPAGE="https://opensource.conformal.com/wiki/spectrwm"
+SRC_URI="http://opensource.conformal.com/snapshots/${PN}/${P}.tgz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-misc/dmenu"
+DEPEND="${DEPEND}
+ x11-libs/libX11
+ x11-libs/libXrandr
+ x11-libs/libXtst
+ !x11-wm/scrotwm"
+
+S=${WORKDIR}/${P}/linux
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+ tc-export CC
+}
+
+src_install() {
+ emake PREFIX="${D}"/usr LIBDIR="${D}usr/$(get_libdir)" install
+
+ cd ${WORKDIR}/${P} || die
+
+ insinto /etc
+ doins ${PN}.conf
+ dodoc ${PN}_*.conf {initscreen,screenshot}.sh
+
+ elog "Example keyboard config and helpful scripts can be found"
+ elog "in ${ROOT}usr/share/doc/${PF}"
+}