summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2009-07-26 18:49:02 +0000
committerCédric Krier <cedk@gentoo.org>2009-07-26 18:49:02 +0000
commitf6393fdf40b8283a73b879f531034fb10ca07135 (patch)
treea7f98db3414eee62c2c683826ed0e575ba13662e /x11-wm
parentFix building with GCC 4.4 and other issues wrt #277937, thanks to Zeev Tarantov. (diff)
downloadgentoo-2-f6393fdf40b8283a73b879f531034fb10ca07135.tar.gz
gentoo-2-f6393fdf40b8283a73b879f531034fb10ca07135.tar.bz2
gentoo-2-f6393fdf40b8283a73b879f531034fb10ca07135.zip
Version bump
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/dwm/ChangeLog7
-rw-r--r--x11-wm/dwm/dwm-5.6.1.ebuild80
2 files changed, 86 insertions, 1 deletions
diff --git a/x11-wm/dwm/ChangeLog b/x11-wm/dwm/ChangeLog
index 2c73dda907dc..71efd1be52c4 100644
--- a/x11-wm/dwm/ChangeLog
+++ b/x11-wm/dwm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/dwm
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/dwm/ChangeLog,v 1.60 2009/05/09 13:54:09 cedk Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/dwm/ChangeLog,v 1.61 2009/07/26 18:49:02 cedk Exp $
+
+*dwm-5.6.1 (26 Jul 2009)
+
+ 26 Jul 2009; Cédric Krier <cedk@gentoo.org> +dwm-5.6.1.ebuild:
+ Version bump
*dwm-5.5 (09 May 2009)
diff --git a/x11-wm/dwm/dwm-5.6.1.ebuild b/x11-wm/dwm/dwm-5.6.1.ebuild
new file mode 100644
index 000000000000..86d714dfa33b
--- /dev/null
+++ b/x11-wm/dwm/dwm-5.6.1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/dwm/dwm-5.6.1.ebuild,v 1.1 2009/07/26 18:49:02 cedk Exp $
+
+inherit toolchain-funcs savedconfig
+
+DESCRIPTION="a dynamic window manager for X11"
+HOMEPAGE="http://www.suckless.org/dwm/"
+SRC_URI="http://code.suckless.org/dl/dwm/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="xinerama"
+
+DEPEND="x11-libs/libX11
+ xinerama? (
+ x11-proto/xineramaproto
+ x11-libs/libXinerama
+ )"
+RDEPEND="${DEPEND}
+ x11-apps/xsetroot"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e "s/CFLAGS = -std=c99 -pedantic -Wall -Os/CFLAGS += -std=c99 -pedantic -Wall -g/" \
+ -e "s/LDFLAGS = -s/LDFLAGS += -g/" \
+ -e "s/#XINERAMALIBS =/XINERAMALIBS ?=/" \
+ -e "s/#XINERAMAFLAGS =/XINERAMAFLAGS ?=/" \
+ config.mk || die "sed failed"
+
+ if use savedconfig; then
+ restore_config config.h
+ fi
+}
+
+src_compile() {
+ local msg
+ use savedconfig && msg=", please check the configfile"
+ if use xinerama; then
+ emake CC=$(tc-getCC) || die "emake failed${msg}"
+ else
+ emake CC=$(tc-getCC) XINERAMAFLAGS="" XINERAMALIBS="" \
+ || die "emake failed${msg}"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install || die "emake install failed"
+
+ insinto /usr/share/${PN}
+ newins config.h ${PF}.config.h
+
+ exeinto /etc/X11/Sessions
+ newexe "${FILESDIR}"/dwm-session2 dwm
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}"/dwm.desktop
+
+ dodoc README
+
+ save_config config.h
+}
+
+pkg_postinst() {
+ einfo "This ebuild has support for user defined configs"
+ einfo "Please read this ebuild for more details and re-emerge as needed"
+ einfo "if you want to add or remove functionality for ${PN}"
+ if ! has_version x11-misc/dmenu; then
+ elog "Installing ${PN} without x11-misc/dmenu"
+ einfo "To have a menu you can install x11-misc/dmenu"
+ fi
+ einfo "You can custom status bar with a script in HOME/.dwm/dwmrc"
+ einfo "the ouput is redirected to the standard input of dwm"
+ einfo "Since dwm-5.4, status info in the bar must be set like this:"
+ einfo "xsetroot -name \"\`date\` \`uptime | sed 's/.*,//'\`\""
+}