summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-04-29 09:53:19 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-04-29 09:53:19 +0000
commit38665fa7f878888a0768e4472c267ac7a35a0d9b (patch)
tree5312ca0db3b5914f3ccfcc1aadade6cd6682b26d /xfce-base/libxfce4ui
parentVersion bump. (diff)
downloadgentoo-2-38665fa7f878888a0768e4472c267ac7a35a0d9b.tar.gz
gentoo-2-38665fa7f878888a0768e4472c267ac7a35a0d9b.tar.bz2
gentoo-2-38665fa7f878888a0768e4472c267ac7a35a0d9b.zip
Version bump.
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'xfce-base/libxfce4ui')
-rw-r--r--xfce-base/libxfce4ui/ChangeLog8
-rw-r--r--xfce-base/libxfce4ui/libxfce4ui-4.10.0.ebuild45
2 files changed, 52 insertions, 1 deletions
diff --git a/xfce-base/libxfce4ui/ChangeLog b/xfce-base/libxfce4ui/ChangeLog
index 46721e1b8cca..5c5cd6dbb2b6 100644
--- a/xfce-base/libxfce4ui/ChangeLog
+++ b/xfce-base/libxfce4ui/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-base/libxfce4ui
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/libxfce4ui/ChangeLog,v 1.40 2012/04/22 18:33:46 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/libxfce4ui/ChangeLog,v 1.41 2012/04/29 09:53:19 ssuominen Exp $
+
+*libxfce4ui-4.10.0 (29 Apr 2012)
+
+ 29 Apr 2012; Samuli Suominen <ssuominen@gentoo.org>
+ +libxfce4ui-4.10.0.ebuild:
+ Version bump.
22 Apr 2012; Samuli Suominen <ssuominen@gentoo.org> -libxfce4ui-4.8.0.ebuild:
old
diff --git a/xfce-base/libxfce4ui/libxfce4ui-4.10.0.ebuild b/xfce-base/libxfce4ui/libxfce4ui-4.10.0.ebuild
new file mode 100644
index 000000000000..b15ddc92fb3d
--- /dev/null
+++ b/xfce-base/libxfce4ui/libxfce4ui-4.10.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/libxfce4ui/libxfce4ui-4.10.0.ebuild,v 1.1 2012/04/29 09:53:19 ssuominen Exp $
+
+EAPI=4
+inherit xfconf
+
+DESCRIPTION="Unified widgets and session management libraries for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/libxfce4"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug glade startup-notification"
+
+RDEPEND=">=dev-libs/glib-2.24
+ >=x11-libs/gtk+-2.20:2
+ x11-libs/libX11
+ x11-libs/libICE
+ x11-libs/libSM
+ >=xfce-base/libxfce4util-4.10
+ >=xfce-base/xfconf-4.10
+ glade? ( dev-util/glade:3 )
+ startup-notification? ( x11-libs/startup-notification )
+ !xfce-base/xfce-utils"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ dev-util/intltool
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+pkg_setup() {
+ XFCONF=(
+ $(use_enable startup-notification)
+ $(use_enable glade gladeui)
+ $(xfconf_use_debug)
+ --with-vendor-info=Gentoo
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+ )
+
+ [[ ${CHOST} == *-darwin* ]] && XFCONF+=( --disable-visibility ) #366857
+
+ DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
+}