summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-12-02 16:28:49 +0000
committerSamuli Suominen <drac@gentoo.org>2007-12-02 16:28:49 +0000
commit1575b1e1f8ba4a64b6a20bac860b390bc86bc8ac (patch)
treeda15e81eda22367820ba67d316c53e36ee7d681a /xfce-base/thunar/thunar-0.8.0-r3.ebuild
parentversion bump (diff)
downloadgentoo-2-1575b1e1f8ba4a64b6a20bac860b390bc86bc8ac.tar.gz
gentoo-2-1575b1e1f8ba4a64b6a20bac860b390bc86bc8ac.tar.bz2
gentoo-2-1575b1e1f8ba4a64b6a20bac860b390bc86bc8ac.zip
Version bump, rename USE plugins to USE trash-plugin and enable it by default using EAPI=1.
(Portage version: 2.1.4_rc4)
Diffstat (limited to 'xfce-base/thunar/thunar-0.8.0-r3.ebuild')
-rw-r--r--xfce-base/thunar/thunar-0.8.0-r3.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/xfce-base/thunar/thunar-0.8.0-r3.ebuild b/xfce-base/thunar/thunar-0.8.0-r3.ebuild
index a05b3f6118d2..4d6b60d286cc 100644
--- a/xfce-base/thunar/thunar-0.8.0-r3.ebuild
+++ b/xfce-base/thunar/thunar-0.8.0-r3.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/thunar/thunar-0.8.0-r3.ebuild,v 1.11 2007/08/28 18:26:30 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/thunar/thunar-0.8.0-r3.ebuild,v 1.12 2007/12/02 16:28:48 drac Exp $
+
+EAPI=1
inherit eutils virtualx xfce44
@@ -12,7 +14,7 @@ xfce44
DESCRIPTION="File manager"
HOMEPAGE="http://thunar.xfce.org"
KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="doc dbus debug exif gnome hal plugins pcre startup-notification"
+IUSE="doc dbus debug exif gnome hal pcre startup-notification +trash-plugin"
RDEPEND=">=dev-lang/perl-5.6
x11-libs/libSM
@@ -31,7 +33,7 @@ RDEPEND=">=dev-lang/perl-5.6
>=media-libs/jpeg-6b
startup-notification? ( x11-libs/startup-notification )
pcre? ( >=dev-libs/libpcre-6 )
- plugins? ( dbus? ( >=xfce-base/xfce4-panel-${XFCE_MASTER_VERSION} ) )
+ trash-plugin? ( dbus? ( >=xfce-base/xfce4-panel-${XFCE_MASTER_VERSION} ) )
gnome-base/librsvg"
DEPEND="${RDEPEND}
dev-util/pkgconfig
@@ -48,7 +50,7 @@ pkg_setup() {
XFCE_CONFIG="${XFCE_CONFIG} --with-volume-manager=none"
fi
- if use plugins && ! use dbus ; then
+ if use trash-plugin && ! use dbus ; then
XFCE_CONFIG="${XFCE_CONFIG} --disable-tpa-plugin"
ewarn "Plugins requires ${PN} with dbus support. Enable dbus use flag"
ewarn "and re-emerge this ebuild if you want this feature."