summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Teaford Cowan <bcowan@gentoo.org>2004-03-10 07:18:48 +0000
committerBrad Teaford Cowan <bcowan@gentoo.org>2004-03-10 07:18:48 +0000
commit763bde335c31dff8313e2e0b866ef8eaeecfe2cb (patch)
tree68980136c0199cec47526fceeb3f06e6cf30b687 /xfce-base/xfce-utils/xfce-utils-4.0.4.ebuild
parentNew release. Closes bug #40713. (Manifest recommit) (diff)
downloadgentoo-2-763bde335c31dff8313e2e0b866ef8eaeecfe2cb.tar.gz
gentoo-2-763bde335c31dff8313e2e0b866ef8eaeecfe2cb.tar.bz2
gentoo-2-763bde335c31dff8313e2e0b866ef8eaeecfe2cb.zip
Bugfix release of xfce4.
Diffstat (limited to 'xfce-base/xfce-utils/xfce-utils-4.0.4.ebuild')
-rw-r--r--xfce-base/xfce-utils/xfce-utils-4.0.4.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/xfce-base/xfce-utils/xfce-utils-4.0.4.ebuild b/xfce-base/xfce-utils/xfce-utils-4.0.4.ebuild
new file mode 100644
index 000000000000..962fba1d5c8a
--- /dev/null
+++ b/xfce-base/xfce-utils/xfce-utils-4.0.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce-utils/xfce-utils-4.0.4.ebuild,v 1.1 2004/03/10 07:18:48 bcowan Exp $
+
+IUSE="X gtkhtml gnome"
+S=${WORKDIR}/${P}
+
+DESCRIPTION="Xfce4 utilities"
+HOMEPAGE="http://www.xfce.org/"
+SRC_URI="http://www.xfce.org/archive/xfce-${PV}/src/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~ia64 ~x86 ~ppc ~alpha ~sparc ~amd64 ~hppa ~mips"
+
+DEPEND=">=x11-libs/gtk+-2.0.6
+ dev-util/pkgconfig
+ dev-libs/libxml2
+ =xfce-base/libxfce4util-${PV}
+ =xfce-base/libxfcegui4-${PV}
+ =xfce-base/libxfce4mcs-${PV}
+ =xfce-base/xfce-mcs-manager-${PV}"
+
+src_compile() {
+ local myconf
+ myconf=""
+
+ use X && myconf="${myconf} --with-x"
+ use gtkhtml && myconf="${myconf} --enable-gtkhtml"
+ use gnome && myconf="${myconf} --enable-gdm"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS INSTALL NEWS COPYING README ChangeLog TODO
+}