summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Teaford Cowan <bcowan@gentoo.org>2004-07-12 16:58:58 +0000
committerBrad Teaford Cowan <bcowan@gentoo.org>2004-07-12 16:58:58 +0000
commitc3e477fc51f1d9199dcfbc1a076d113dd661918d (patch)
tree3fb617eab33bcc23c1ee52e94ef1241dc2af147b /xfce-base/xfce-utils/xfce-utils-4.0.6.ebuild
parentVersion bump. Bugfix release on stable branch that fixes cropped icons with m... (diff)
downloadgentoo-2-c3e477fc51f1d9199dcfbc1a076d113dd661918d.tar.gz
gentoo-2-c3e477fc51f1d9199dcfbc1a076d113dd661918d.tar.bz2
gentoo-2-c3e477fc51f1d9199dcfbc1a076d113dd661918d.zip
Version bump. Bugfix release on stable branch that fixes cropped icons with many others.
Diffstat (limited to 'xfce-base/xfce-utils/xfce-utils-4.0.6.ebuild')
-rw-r--r--xfce-base/xfce-utils/xfce-utils-4.0.6.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/xfce-base/xfce-utils/xfce-utils-4.0.6.ebuild b/xfce-base/xfce-utils/xfce-utils-4.0.6.ebuild
new file mode 100644
index 000000000000..2188a1bc377d
--- /dev/null
+++ b/xfce-base/xfce-utils/xfce-utils-4.0.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce-utils/xfce-utils-4.0.6.ebuild,v 1.1 2004/07/12 16:58:58 bcowan Exp $
+
+IUSE="X gtkhtml gnome"
+
+DESCRIPTION="Xfce4 utilities"
+HOMEPAGE="http://www.xfce.org/"
+SRC_URI="http://www.xfce.org/archive/xfce-${PV}/src/${P}.tar.gz
+ http://hannelore.f1.fhtw-berlin.de/mirrors/xfce4/xfce-${PV}/src/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~ia64 ~x86 ~ppc ~alpha ~sparc ~amd64 ~hppa ~mips"
+
+RDEPEND=">=x11-libs/gtk+-2.0.6
+ dev-libs/libxml2
+ =xfce-base/libxfce4util-${PV}
+ =xfce-base/libxfcegui4-${PV}
+ =xfce-base/libxfce4mcs-${PV}
+ =xfce-base/xfce-mcs-manager-${PV}"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ local myconf
+ myconf=""
+
+ use X && myconf="${myconf} --with-x"
+ use gtkhtml && myconf="${myconf} --enable-gtkhtml"
+ use gnome && myconf="${myconf} --enable-gdm"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS INSTALL NEWS COPYING README ChangeLog TODO
+}